Libary not registered- getting this error when using excel application scope

image

hi please help me in this

I’m assuming you have Microsoft Excel installed?

What version of Excel / Office?
What version of UiPath.Excel.Activities are you using?
What is your OS version?

Please provide the detailed logs from the error, they often indicate what is wrong.

Hi Nagarjuna,

You can perform following steps and try running your automation again.

Step 1. Go to Run Prompt and Type “regedit” and click ok
Step 2. Expand HKEY_LOCAL_MACHINE
Step 3. Expand Classes
Step 4. Expand TypLib
Step 5. Expand 00020813-0000-0000-C000-000000000046
Step 6. Select 1.8
Step 7. Right Click on 1.8 and Delete this.
Regards,
Tuhin

Out of curiosity why the specific version @Tuhin_Samanta? Wouldn’t it depend on what other software is installed on the host and the version of COM library installed?

For myself, I have a copy of Office 2007, 2013, and 2016 installed and subnodes under Computer\HKEY_CLASSES_ROOT\TypeLib\{00020813-0000-0000-C000-000000000046} for 1.0, 1.6, 1.7, 1.8, and 1.9 and not run into any issue yet.

thanks for your response

in my machine i am not finding any classes under root.

excel version-2016
uipath.excel.activities version-2.5.0
uipath studio version-2018.4.1
os -windows 7 proffesinal

hi tuhin
i tried but its not working

Hi @twhitehead,
Thanks for your response! I wrote it as a common solution of the problem. Yes, there can be other iss es as well.
Regards,
Tuhin

Hi Nagarjuna ,
have you tried reinstalling uipath packages relevant to excel

In my experience there can often be a number of possible issues that cause this particular error. Googling the issue, when all other steps have failed, often a [full] repair of Office will resolve your issue.

1 Like