Level3 Assignement 2 Yearly Report - Performer Workflow - Excel Application Scope Error

Please help with this trouble, im stuck in the excel aplication scope activity (a headhache activity btw) that i need to use for the “write range” in the CreateYearlyReport.xaml. It says “error opening workbook” the path that im givin in the out_yearlyreportpath argument. The value is: C:\Users\Philippe\Documents\UiPath\YearlyReportPerformer\Data\Temp\Yearly-Report-2018-FR329083.xlsx . The error says: error opening workbook, make sure have excel". Of course i have excel installed… Could you figure whats going on? Thank you i appreciate it

Please try test the only excel application scope activity in Test.Xaml file , If it works , then you need to open the process Manager (Task Manager) and see any Excel process is getting created or not
It could be because of cache
Please restart the machine and Uipath studio once

1 Like

could be that? Ok i will test what happens, thanks in advance for your help

i’ve tested… what im doing wrong? im giving a path of an excel file that exists and still the same error message

the problem is probably in regedit, look into the TypeLib-key for Excel and Outlook there should be a folder named “0” and inside that folders named Win32 and Win64. change both keys values to match current installation of EXCEL.EXE and MSOUTL.OLB. Now UiPath finds them.

Hi , If the solution works for you , pls mark the topic as solved

Hello, nope i’m still stuck, i cant reach that part of the regedit i havent found that folder, can i use another way or activity to proceed with the createyearlyreport? i mean if i have this problem with the scope, maybe theres another way to create the file and put the info needed to proceed…

Thanks anyway

Ok, i have already solved this issue with a write range activity from the workbook. Thanks anyway for the help

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.