Level 3 - Assignment 2

Hi all,

Trying to conclude the Assignment 2, i ran into a series of severe issues:

  • at first, although Queue is full of items (#20), my PROCESS ends with an error: “Process finished due to no more transaction data”

  • i tried to follow yesterday’s workaround (delete queue, recreate queue, upload items) but it didnt work

  • i restarted my VM, and now i get an even worst error:
    "14:24:21.3855 => [ERROR] [UiPath.Studio.exe] [1] System.AggregateException: One or more errors occurred. —> System.ServiceModel.FaultException`1[System.ServiceModel.ExceptionDetail]: The message with Action ‘http://tempuri.org/IUiPathRemoteDuplexContract/IsAlive’ cannot be processed at the receiver, due to a ContractFilter mismatch at the EndpointDispatcher. This may be because of either a contract mismatch (mismatched Actions between sender and receiver) or a binding/security mismatch between the sender and the receiver. Check that sender and receiver have the same contract and the same binding (including security requirements, e.g. Message, Transport, None).

Server stack trace:
at System.ServiceModel.Channels.ServiceChannel.HandleReply(ProxyOperationRuntime operation, ProxyRpc& rpc)
at System.ServiceModel.Channels.ServiceChannel.Call(String action, Boolean oneway, ProxyOperationRuntime operation, Object ins, Object outs, TimeSpan timeout)
at System.ServiceModel.Channels.ServiceChannelProxy.InvokeService(IMethodCallMessage methodCall, ProxyOperationRuntime operation)
at System.ServiceModel.Channels.ServiceChannelProxy.Invoke(IMessage message)"

any ideas?

I restarted my VM, and once opened the project in UiPath Studio, i get the following info:

“Assets file has not changed. Skipping assets file writing. Path: C:\UiPath_EX_ASSIGNMENT 2\RFW_L3_PERFORMER.local\AllDependencies.json”

??? do i need to reinstall the studio?