Level 3 Assignment 2 Performer - UploadYearlyReport not writing correct File Name

I am trying to complete the 2nd assignment in Level 3 but I am very stuck. It has been almost 2 weeks and I cannot see how to correct the situation. When I run the project in debug mode, it always stops in the UploadYearlyReport part of the process. When the pop-up window opens for my bot to upload, it always writes Data\Temp in the File Name section instead of the Year-Report2018-TaxID xlsx.


System1_UpoadYearlyReport.xaml (14.1 KB)

Please take a look and I appreciate any and all assistance on how to move forward.

Thank you.


You really only have in debug mode? In your Activity I see that you write in

_ReportPath.ToString+ “[k(enter)]”

into this field. Which value you set for this input argument at invoking of this workflow?

When I debug the workflow, I put in “Data\Temp” but when I run the entire project I clear the argument’s default value and let in read from the Config file. In both cases, Data\Temp gets written in the File Name space instead of the xlsx file.

Problem always in front of pc😁. pls provide xaml where you invoke this workflow?

Are you sure that you work with the right excel instance? After closing there is no running excel process? Once I had this because if not proper closing of excel.

Excel is not open when this happens. Also, I forgot to mention that this is from the Advanced Training Level 3 Assignment 2

Pls provide workflow where you invoke this workflow.

I know the problem is within the “Type Into” activity for File Name and with in_ReportPath.ToString+ “[k(enter)]” …but I am struggling to find why it cannot write the files from the file folder.

Still stuck…

So it is not able to find the correct file path and upload files.

Hi @Redcorolla5,

Try not give type into wit simulate type checked (if it is), also please give some delay between keystrokes 300ms. Then try.


Hello ShenkiSinghai,

I made the changes per your suggestions but the same error resulted…

Could you review my workflow?

Can you please share the screenshot of how you are assigning value to your Argument, also please share the screenshot of Properties of TypeInto activity.


The screenshot above shows the arguments and to the right, is the properties panel of the Type Into activity for:


TypeInto looks file. Regarding argument, I want to check from where you are assigning value to In_ReportPath. I need to see that.

I think I am making it worse…now in trying to fix my upload issue…the workflow stops immediately after login and wont extract data. I am going to send you my xaml for my project. I am not looking for easy answers, just some guidance to help me work through this.

Any guidance on where I find the issue? Thank you