Level 3 - Assignment 2 - PERFORMER PROCESS

Hello

Working on the last assignment of L3 (Generate Yearly Report for vendor), and I get the following error in the Performer Process:

“Process finished due to no more transaction data”

  • Queue has data populated from DISPATCHER Process
  • Packaged is published and robot is connected

In GetTransactionData.XAML, make sure Get Transaction Item activity is present at the top and for the activity you are using correct Queue Name and the output of this activity is assigned to “out_TransactionItem”

checked that - didnt work…

Created a new project, just logging in to the ACME web app, and trying to access QueueItems.
I get the following errors:

Error getting transaction data for Transaction Number: 1. Unable to find a constructor to use for type System.Data.DataRow. A class should either have a default constructor, one constructor with arguments or a constructor marked with the JsonConstructor attribute. Path ‘Status’. at Source: Newtonsoft.Json",

and right after, process closes with:
“Process finished due to no more transaction data”

Is there a complete project i could have a look at? I’ve spent many hrs on a profound step which doesnt seem to work properly.

Transaction Item should be Queue Type.

it is

I deleted the queue, re-ran the previous assignment (to re-populate the queue items) and I can finally read items from the Queue.

Now i’ve a selector type of error:
Cannot find the UI element corresponding to this selector:

It means it unable to find the UI element that the activity is interacting.
Please check the activity where the error is thrown.
Fix the selector.

hi Karthik,

I still get the same error "Process finished due to no more transaction data”, although i deleted the queue and added queue items (re-ran Dispatcher).

I noticed that all items in my queue are in the status “In Progress”. Does it mean they’re not “commit” yet and PROCESS cannot access them?

It means, your performer had got the transaction items in your workflow.

But the transaction status is not set.

Can you manually check if the work items are closed in ACME portal.
If they are in closed status and no error occurred, then you are not setting the transaction status.

Make sure that you have Set Transaction Status Activity is present in the SetTransctionStatus.XAML workflow.

Hi Karthik,

I keep running on strange errors. I didn’t handle properly the pop-ups for Save As, and had to re-run the Dispatcher (to create new queue items). But, I deleted my queue, recreated it, my Dispatcher is not working due to the following error:

19.2.0+Branch.master.Sha.21b678a4c3a8b1362fcdd6e92496f991e5a7da37

** The message with Action ‘http://tempuri.org/IUiPathRemoteDuplexContract/SubscribeToEvents’ cannot be processed at the receiver, due to a ContractFilter mismatch at the EndpointDispatcher. This may be because
of either a contract mismatch (mismatched Actions between sender and receiver) or a binding/security mismatch between the sender and the receiver. Check that sender and receiver have the same contract and the same binding (including security requirements,
e.g. Message, Transport, None).**

Any workarounds?

Any suggestions for the selectors? I’m running out of time on this…

N.

Hi @nikosan

There are similar threads in the forum for the same issue. I guess this issue occurs because of Orchestrator and studio are not same versions. Something like that.
Please search in the forum and apply the solutions suggested.

Regards,
Karthik Byggari

Confirmed that there was an incosistency of UIPath Studio and Orchestrator.

My final issue with the assignment, is that i cannot select the “save as” button. I get the following error:
Invoke System1_Create_YearlyReport workflow: Cannot find the UI element corresponding to this selector:

How can i properly update the selector?

Even tried to add a recorded session, of selecting the down arrow and “Save As” but ran into the following errors:

Click ‘menu item Save as’: Cannot find the UI element corresponding to this selector:

Invoke System1_Create_YearlyReport workflow: Cannot find the UI element corresponding to this selector:

Did you solved the issue or still facing the issue?

Still facing. No progress.

Please check your messages. I sent you the details.

Hello again

Tried to run your process, replacing mine, but I get the following error:

System exception.The values provided for the root activity’s arguments did not satisfy the root activity’s requirements:

‘System1_CreateYearlyReport1’: The following keys from the input dictionary do not map to arguments and must be removed: in_Year. Please note that argument names are
case sensitive.

Parameter name: rootArgumentValues at Source: Invoke System1_Create_YearlyReport workflow

I have checked the params being passed to this process… I don’t get it

Thank you,

Nikos

The replace doesn’t work. Because the arguments list and arguments type that your earlier workflow and my workflow differs.

I gave you the workflow for understanding the activities and selectors part.

Please refer the workflow process and selectors and try to implement the same in your workflow which fits your design.

hello all

  1. I’ve noticed that my process runs extremely slow - it could even take 30+ mins to process the queue messages.

Q: is there a “fast forward” type of option?

  1. my process saves the csv files. but after a while, I get several time-out errors: any ideas?