Level 3 - Assignment 2 - Calc Security Hash - Error in Establishing or Using URL Config Entries

I have made a mistake in my setup of the URL values in the config file or in the arguments. I am not able to use the System1URL argument to pull the System1 login page URL from the Config as a result. (Same issue with the SHA-1 URL also.).

The Settings tab in the Config file looks like this. System1URL is present.
image

The following arguments were initialized on the System1_Login.xaml.
image

I get these same results if I run the InitAllSettings.xaml before running the System1_Login.xaml or if I don’t.

Attempts to use the values in the “Open Browser” sequence result in errors as shown. I would appreciate assistance in what I have missed here. If I put the actual URL in the field, the sequence for logging in runs with no issues including credential usage.

image

u can try : System1URL is https://acme-test.uipath.com/

@jamiejam

  1. First create in_Config argument of type Dictionary in System1_Login workflow and pass Config argument of type Dictionary to it.

  2. Then inside the workflow use like this.

in_Config(“System1URL”).ToString

u can try System1URL = “https://acme-test.uipath.com/

Thanks very much for the followup.

Is this the type you are referring to?

Or is it this one?

@jamiejam

Yes… First one.

Updates made. No errors are present. I still get an error when running the workflow however and I believe it is because I have not addressed the part properly where you said " and pass Config argument of type Dictionary to it." I passed types of String and String as shown below. Would that be the issue? Again, your support is most appreciated.

In case it helps https://forum.uipath.com/u/lakshman, the config.xlsx contains this information.
image

When this is added error messages are gone until runtime. When I run, I get the message that “Message: Object reference not set to an instance of an object.” with an Exception Type: System.NullReferenceException.

If you could take another look, I would appreciate it.