Level 3 Assignment 1 Value does not fall within the expected range

orchestrator

#1

Hi, So I am getting this error:
image
I Suspect it has to do with the way I am closing the application. I had a close tab activity inside the attach Browser. The attach browser had an output variable called “Browser” and the close tab then had a the same variable as input. I have also tries using a close application outside the attach browser, but it gives the same error.
I also tried removing this variable, same issue. Please help.


Level 3 assignment 1: the given key was not present in the dictionary. at Source: mscorlib
#2

How are you indicating the browser in the attach browser?
You should only indicate the browser body section not the whole application.


#3

Hi, This is the error I am getting.
image
Please help. I have built the entire project, and I am now trying to debug this. If there is anyone that can help we work through this project and debug the thing that would be great. I do not understand all the errors that are displayed.

My project currently opens ACME, gets the data table and displays the number of items in my Data table. Then this error happens.
Please help


#4

Can you verify if you indicated the browser correctly where the attach browser is being used?


#5

HI Ithink I am doing it correct, Please see screenshot


Does the error in grey in the first screenshot mean anything that I need to change first


#6

yes, can you add a screenshot of your Config file?
I think you are missing something there


#7

Hi Here are of all sheets




I Have no idea where the problem may be


#8

I think you have deleted one entry which is used in the workflow.
logF_BusinessProcessName

It is used in the Init state log activity. Either remove the log or add the entry in the config :slight_smile:


#9

Thank you very much, it worked. Seems to log in to do hash, but then fails and gives this error. Could you help again please?
image


#10

Seems you have missed an argument mapping for transaction number.
Can you specify where the issue is?


#11

Hi, Yes I can. Run the debug. Seems to happen in the Get transaction data activity. See image below:
image
I Think I am pulling in the arguments incorrectly from the extract data table activity


#12

In the TransactionData state where the GetTransactionData is invoked have you mapped the in_WIList argument?


#13

This topic was automatically closed 24 hours after the last reply. New replies are no longer allowed.