Level 3 - Assignment 1: I need help with a consistent selector issue with the Get text activity

Hello, I would be very grateful if someone could help me with this issue.

When trying to use the Get Text activity or get full text activity to retrieve the Hash Code for the first Transaction number, I am having a selector issues. I have tried to use internet explorer to find a more consistent selector but haven’t had any luck. The GetHashCode workfile runs by itself however still doesn’t work when the whole automation is ran.
My selector currently is:

but I have tried other versions.

Can you try the same with get text activity and select the text again so that the selector will change

I have tried this multiple times, doesn’t seem to work

Hi @gav_b ,

Try you can like this
Open Ui explorer and select aaname attribute you pass the wildcard in the text like

hi @Navyavara
I have tried this and seem to get the same issue. I would be happy to share my workfiles if you feel this would help.

Whether you are using the Get Text inside the Attach Browser ???..

@Manish540 yes the get text is inside an attach browser

Open in UIExplorer , try to get the ParentID, Aaname and Tag selectors for the Get Text Activity.
This may solve your problem.

Check with this below selector,
"<“webctrl tag=‘SPAN’ aaname=’*’ parentid=‘sha1-title’ />”

@Manish540 Thank you for the help, that seems to of fixed the selector issue.
I am now having an issue with the go back activity

You can use navigate to activity instead of go back.

This is pretty strange, but I have realised that my automation will only proceed with the get text activity if manually click the hash button on the SHA1 online website even though I have included a click activity in my workflow. Do you have any idea why this may be happening?

Whether you are adding the get text activity before the click activity???..

I am unsure what you mean, the click activity has to come before the get text activity to generate the new hash code


Instead of using Get Text use Get Full Text activity.



Can you send me the screenshot of the error…


I believe the issue is the selector provided is still not reliable, it works sometimes but not always. so it is the same selector error occurring

I have Used the get full text activity too but have had no luck, even when using a dynamic selector

Send the workflow.


1 Like