Level 3 assignment 1 (Getting 0 score with failed)

I’m uploading (Calculate Client Security Hash) assignment1(Level 3) on Uipath Academy but getting 0 score with status failed, while programme is running correct and giving correct output.

Please help

Hi welcome to the community!
do you have a screenshot of one of the client security hash result string?

Thanks Sir, for quick response !
PFAB

image

1 Like

i mean taken out of the acme web site… you need to make sure all items are different from each other and have no spaces in the 3 parts and also are separated by - and not ,

Hello @Vinay_E_Robat

  • Please check that all the WI5 items in the ACME test site has a status of “Completed”
  • After verifying then please DO NOT reset the test data before submitting your assignment.
    Simply put your assignment folder in a zip file and submit it directly without resetting the test data.

Sample:

  • If you’ll still face any issues after this, then please upload your assignment folder so that I may have a quick look and give you further assistance.

Have a great day! :vulcan_salute:

Sir,
I have run the program and converted in ZIP and uploaded on academy.
We have not reset the data after uploading.
please share your email ID. I’ll share project.

I’m unable to upload on forum becuz new user.

Thank you so much for your valuable time.

1 Like

@BenMar… Project has been sent !

1 Like

I received your email @Vinay_E_Robat. I’ll take a look at it asap.
Have a great day! :vulcan_salute:

@BenMar Thanks a lot!

1 Like

@BenMar Sir, please response !

1 Like

Good day @Vinay_E_Robat apologies for the late reply.

  • I was able to get a look at your workflow, overall the assignment was made correctly and should have no issue with passing the grading criteria.

  • However, when I ran the assignment, I found that your SHA1Online_GetHashCode was susceptible to selector errors, specifically the ‘Get Full Text Span’ activity.

  • Although I can see that you were able to run the assignment successfully and without errors given your screenshot. There can still be a chance that the “Hash results” per each transaction were not being added as comments in the updated work items.

  • My recommendations:

    • Include the Type Into activity with value of in_Hash & the Click activity inside the ‘Do’ sequence of the Attach browser activity.
    • Replace the Get Full text with a Get Text activity and indicate the necessary UI element (Hash result).
    • Use UI explorer to:
      • Add the selector item/property “aaname” and use a wildcard (*) for its value.
      • Remove/Omit the “id” selector property with the value of result-sha1.
    • Remove the ‘Go back’ activity as it’s unnecessary since you have selected the “Empty field” option for your Type Into activity.
    • Add a log message to display the value of out_Hash per Transaction so that you can see if the Hash result is being captured by the Get Text activity.
  • Once you have successfully run the entire assignment and are certain that there are no errors or even warnings, please verify that the WI5 items in the ACME test site changed their statuses to “Completed”. Then as I said previously, DO NOT reset the test data before submitting the assignment.

@BenMar Really appreciated your help/support !
I have added “-” syntax place of “,” and use Trim() function for removing space.
Then it worked fine and I got passed with 100/100

Corrected screen shot is below.

1 Like

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.