Level 3 Assignment 1 - Failed Many Times

I’m sorry I must not be very clear on what I’m trying to say.

I am also able to generate it using the automation but the problem is when the second transaction comes up it reads the previously generated hash code and not the new one.

Generating the hash code is not the issue.

This can be seen in the screenshot.

Below is the workflow I am using. I have included a default value which when run extracts the hash code.

in order to recreate the issue I wrote a new input value and generated any random hash code. Then when I ran the workflow again it grabbed the previous one (sometimes). I ran it a few times to recreate it but it always manages to do it after 2 - 3 tries.

SHA1Online_GetHashCode.xaml (8.7 KB)

You mean to say that workflow is generating the right HashCode but variable/out_Argument is not getting updated with the new one right?

Yes. On the first attempt the variable/out_argument is getting updated correctly.

On the second attempt is when it doesn’t get updated correctly.

hmmm well in that case you can try to open the browser in SHAOnline GetHasCode workflow instead of attaching one and close it once you get the code, that would assure you that you are getting a fresh value every time

Thank you but I guess I was trying to figure out what the actual problem was and not a workaround.

I have also tried using full selectors instead of partial ones and it appears to be working without needing to close it and open it every time.

I would still however like to know what the issue is but I guess I will just have to keep it in mind. Thank you for your assistance.

The problem is you have attached the browser not opened it everytime and generated the hashcode, so when you go to the page second time the page has to be refreshed so in second transaction HashCode is already there on the page, that is why it is picking up the previous one and then the value gets updated. You can do one more thing to test it, add some delay between Click Hash Button and Get Text activity around 2-3 secs.

Thank you I have tried the delay and didn’t have any luck.

I did notice that it takes up to a minute sometimes to read the hascode which I find really weird. Because the first time it only take like 4 seconds. When I use full selectors and no attach activity this isn’t a problem anymore which I don’t get.

And the reason I use attach and not open is because in the PDF it mentions to start up all the applications beforehand in the initialize phase.

okay no problem give it a try to open the browser instead and lets hope for the best. Yes you are right in PDD file it says to attach the browser

Hey!!!

Sorry for the delay!

Have you solved it yet?

Try to add a “go back” action at the end.

This is wat happened to my.

Script is running fine in local but always got 0/100.

solution is :

  1. Should complete all the record in the work items
  2. After all the records completed do not reset the data
  3. Add refresh browser activity(to work items page) after updating the hash key and closing that window

Thanks to @richardli and @priyanka.yadav18

Refer : Advanced Training(Academy 2) Assignment 1 evaluation error - #36 by bdale04

How long normally is the evaluation? I uploaded mine last Friday Night and its is till waiting for evaluation status. :frowning:

1 Like

It doesn’t take much time 2-3 minutes, as the evaluation system is automated there might be some glitch which is restricting the result in your scenario, please try to upload it once again if it allows or log off the academy clear the cookies and then try.

I already tried logging in to another computer but still the same results.

Hi prankujoshi,

I am getting the below error, not sure what needs to be corrected in “GetTransactionData”

“message”: “Assign Transaction item: Index was outside the bounds of the array.”,
“level”: “Error”,
“logType”: “Default”,
“timeStamp”: “17:14:53”,
“processVersion”: “1.0.0.0”,
“jobId”: “4e6a8723-61be-4195-9b54-f6df661a4d91”,
“robotName”: “NAM\RPEERANNAW001”,
“machineId”: 0,
“fileName”: “GetTransactionData”,
“logF_BusinessProcessName”: “Framework”

{
“message”: “Error getting transaction data for Transaction Number: . Index was outside the bounds of the array. at Source: Assign Transaction item”,
“level”: “Fatal”,
“logType”: “User”,
“timeStamp”: “17:14:53”,
“processVersion”: “1.0.0.0”,
“jobId”: “4e6a8723-61be-4195-9b54-f6df661a4d91”,
“robotName”: “NAM\RPEERANNAW001”,
“machineId”: 0,
“fileName”: “Main”,
“logF_BusinessProcessName”: “Framework”
}

Not sure how to resolve this issue

I agree, we need feedback from the evaluation. If the project performs all the tasks, how can it fail?

I have the same issue. I try upload the assignment No. 1 but always “fail”.

same with my case also

@AnthonyThk37,
Hi Anthony, were you able to resolve this issue? I know it has been long but i was hoping you could provide the solution to this problem which a lot of people are still facing.
I’m having the same issue, workflow is running fine, it’s generating the hash code perfectly and the first transaction is correct. However for 2nd transaction its taking the 1st transaction’s hash value, for 3rd transaction it’s taking second hash value and so on…

Will ‘Go back’ activity be able to solve the issue? Or any other method, if any.
P.S. I tried adding delay for 3 seconds which is giving page enough time to load but still it’s printing the old hash value.

Any help would be much appreciated.

I am facing same,@prankur joshi can you you please help me.