Level 3 Assignment 1 - Failed Many Times


I really dont understand what’s going on here… :tired_face:

not the Hash Code, print your formula, ClientID-Client Name-ClientCoutry

1 Like

It looks correct, reset your test data, run your program once again and if successful then submit the Assignment

1 Like

I reset data and tried many times, still the same problem.

only the first one is correct.

Is there any execution error in output window? Also I hope you have not reset the data after submitting the project

1 Like

No…everything looks fine from the output panel… so… im really confused…

Try to debug with slow step I am sure you will find something. Also I hope you have created this as is given in PDD file

I’ve finally done my assignment 1, the “go back” activity cant work so that always get the previous hash code for next.

Now I’m working with assignment 2, in the “GetTransactionData” said “If the next page exists, set the output argument out_TransactionItem to the value of the current page, namely in_TransactionNumber.” and “TransactionItem is the number of the page with work items”, I don’t understand this part.

It just says that your Transaction Item would be a page number if it exists on Work Items Page. So say if you have 5 pages then transaction will be done 5 times


There is no “Download Reprots” exists in config file, should I create a temp one in “Assets”?

my transaction number increased while the page never change

Craete a folder in your project Data\Temp. Save all reports in Temp folder. Config file setting tab should have this -

Everytime you run performer make sure Temp folder is empty

Thank you!!!

@PrankurJoshi
Hi, I still have problem to working my dispatcher perfectly…I don’t know which part is wrong…
Process.xaml (14.9 KB)

Process flow looks good to me…can you attach a screenshot of output pane where this fails

Did you figure out the answer for this? I’m also getting the same problem.

I also don’t see how the data looks correct @PrankurJoshi. If the first transaction number 1 has input details of HT69354-Hilario Weitzel-Italy and the output is 1c31a4b… and the second transaction has different input details of FU72098-Ervin Wald-Romania and the output is 1c31a4b37…

Am I missing something here?

If you dont see any issue in your workflow, then reset the test data, run your program and then submit the assignment. If this does not work please attached screenshot of your output to help me understand what is going wrong

1 Like

This screenshot from @ilemon is exactly the issue I am facing. The problem I don’t believe is with the test data. I believe the problem is with the workflow running at full speed. Perhaps the robot reads the hash code before it updates the result. I’ve changed the property on Get Text > WaitForReady to COMPLETE and I am still getting the issue however so perhaps my theory is incorrect as it should be reading the newest hash code. Another reason why this may also be occurring is that I’m not using the Go back Activity as it is always throwing an error when trying to go back: “The requested resource is in use”

Can you also please answer my first question as to how the data looks correct? I’ve also tried typing these values directly into SHA1 and it appears the hash codes should be different.

I generated it manually -

there might be possibility that your formula is not trimmed or having whitespace somewhere. Also please check the workflow from generating Hashcode from SHAOnline