Level 3 Assignement 1 question


#1

Hi,
i started with the first task of level 3 certification. I build the whole workflow, When the Init parts is running, the following error message appears: “No assets are defined”.
Means that, assets in Orchestrator or in the asset table in the config file ?
I defined an asset for credential in Orchestrator, but the asset table in the config file is empty.


#2

It could be both on Orchestrator and in Config file as well. Check the Asset name in Config file sheet “Assets” and same asset name should be there in the Orchestrator. if you are not fetching credentials from Orchestrator you can ignore them both.

But firstly you would have to check that where the actual error is occurring.


#3

ok, thanks for your answer. I have yet to get used to it, so that the process runs flawlessly.
In my understamding the credential parts with Orchestrator entries are the following:
Credential name and value under “Settings” in the config file (for e.g. System1Credential).
The same credential name in Orchestrator under “Assets” with password and username
In the workflow initAllApplication.xaml (contains the login-workflow for the acme-test.com) must be an in-argument for Credential "in_Conig(“System1Credential”).ToString, ok ?


#4

Correct, just mention the same Asset name what is in the orchestrator


#5

Hi Prankur,

When I try to run in InitAllSettings workflow receiving warning to use Get Asset Credentials than Get Asset. The asset name is same in both Config and Orchestrator. Any help would be greatly appreciated.

Thanks.


#6

Hi Prankurjoshi,
thanks for your help. At the moment my login process (getAppCredential.xaml) stucks with error message “Get Orchestrator Credential Faulted”, but as you can see the arguments looks like fine. I dont know why ?
In the try section under “Get Orchestrator Credential” i have the argument “in_Credential”.
In the Orchestrator i have defined the Credential “System1_Credential” and the robot is connected. What is the problem ? Can you help ?


#7

Have you created asset in Orchestrator?


#8

Have you created asset in Orchestrator? If yes try to create a separate workflow take on one activity Get Credentials and see if its working fine, it will help you in understanding what is going wrong in your workflow


#9

Yeah created asset in the Orchestrator and provided in Config file Asset sheet. Below the screen print for details.

Created asset name UiDemoCredential in Orchestrator.

Below the asset name in Config file.

Running the InitAllSettings workflow through _test.xaml.

Receiving below error.

How can we overcome this? Do i Need to use get credentials or other work around. Your help will be greatly appreciated.


#10

Try a workaround to verify, just put the Asset name in the activity property do not get the Asset name from Config file. Get Credentials activity will fetch the credentials directly from Orchestrator then


#11

Thanks. Tried using Asset name but no luck. Just would like to know how you have solved this issue during Assignment 1. If possible can you please have a look into your InitAllSettings and update the activity used. Thanks in Advance.


#12

I hope your GetAppCredentials.xaml workflow would be looking like this -

and you have invoked this GetAppCredentials in System1_Login workflow like this -

image


#13

GetAppCredetia ls is working fine. All I have issues with InitAllSettings work flow. Can’t we use get asset on credential asset type?


#14

Log messages where you think error would occur like this -

image

At start and end this way we would be able to track where the actual error is.

And if you want to get credentials from Orchestrator you would have to use GetCredentials activity only. To See you workflow is working or not just type the UserName and Password in Type Into activity


#15

Yeah, the error receiving in InitAllSettings work flow. In existing (REFramework) we are getting asset name and assigning to AssetValue. Do you have any idea where the AssetValue being used?

If possible could you please send me the screen shots of InitAllSettings workflow from assignemnet1.


#16

make sure that all the Assets that are in Config.xlsx must be there in the Orchestrator with exactly same name because your are looping on every asset name from excel sheet.

Asset in the orchestrator can store anything you want like this -


#17

Thanks. All assets are defined with same name and no issues with accessing those in Individual workflow.
If possible please send me the screen print of InitAllSettings.

Thanks.


#18

Hello @Udayrayalla, I was also facing same issue which I fixed by using “Get Credential” instead of “Get Asset Value”. Also I commented “Set Asset Value” which is not required. Below is screen print for your reference. Let me know if you still facing issues.


#19

Thanks Navneet, Yeah I have used get asset instead credentials.

Thanks,
Uday


#20

Hey @Udayrayalla, Can you please mark my post as ‘Solution’ if it resolved your issue?