Level 3 - Advanced training problems with RE Framework - Runs, but nothing happens?

I am working through the UI Demo Walk-through from Section one of the advanced training, and I’m struggling to get the steps working as written. I’ve followed the steps, and on this one:

It is supposed to work, but it doesn’t. Nothing happens.

I created a UI Demo sequence.
I then create an Argument called “in_Credential”:

I add the invoke Workflow file GetAppCredentials.xaml, and set the out_UserName to the variable I created “user name”, out_password to a secure string variable “password”, and assign “in_Credential” to argument created in the previous step to in_Credential.

I add the Type into and click steps, and I run it. Everything runs fine and as expected from this sequence. It is pulling the credentials from the Orchestrator asset and logging in.

I then go through the next step in the InitAllApplications.xaml - I add an invoke workflow file for UIDemo_Login.xaml, Import arguments and set the following:

I then go to run _Test.xaml as instructed - Nothing happens.

If I try to run InitAllApplications by itself I get the following error:

image

Any ideas? I wish the steps were written a bit more clearly for this training.

Looking at the error message seems there is an issue with the Open aaplication activity itself.
have you done the below?
set filename path to in_Config(“UiDemoPath”).ToString

Hi nadim - yes, I’ve set the File Name to in_Config(“UiDemoPath”).ToString, and it’s an asset in the config file.

Well in this case i will need to have a look at what you have implemented.
can you share your project?

Sure, it’s just the bare bones REF template, with the changes made according to the training steps. I’ve attached the files. UIPath_REFramework_UIDemo.zip (1.7 MB)

Have you created an asset in Orchestrator for UiDemoPath?

Hi - Yes, the file path is created as a string asset in Orchestrator.

i ran your process an its working as expected.

Are you executing your main.xaml file each time? otherwise your config will be null and you will receive the null error.

I’m not executing Main at all , I tried Executing InitAllApplications by itself.

Sorry, but it will not work that way. If you want to standalone execute the xaml you will have to make sure all arguments are passed.
Please run the main so that the config is loaded and your process which is configured to use these arguments/variables between workflows/state machines will execute correctly because you have created a framework based business process.

Ok, the problem was with the documentation in the training - when I ran it from Main, it worked just as expected. When I ran the _test.xaml as instructed I ran into the issue. Thanks!

1 Like

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.