Level 3 Advanced Training Assignment 2 Acme Login Error

I am working on the “Generate Yearly Report” assignment and trying to get it done by using sequence rather than RE template. I have been successful in doing the same for Assignment 1(Client Security Hash), however, there seems to be something wrong with the workflow (login for Acme) and as far I know everything seems to be in order. Here’s the screenshot of the error I ran into when I tried debugging.


Thanks in advance.

You invoked the workflow,
Did you import and configure the arguments in that workflow ?

Yes. I’m getting input arguments from getappcrenetials workflow from orchestrator. And i mapped those arguments to this workflow with InCredential Username and Password.

This generally happens when you don’t initialize the variables.
Can you share your workflow?

here i am uploading the screenshot of arguments i declared in get app and initallInitAllImpoArgu

I think you are getting confused. What you need to do is.

  1. Get the username and password from orchestrator - use get credential activity and store the output into two arguments (out_username and out_password)
  2. Pass the output arguments into the process workflow and assign them to local variables
  3. Initialize two in_arguments in the login workflow (import them) and assign the local variables to those in_arguments.

Your workflow will run fine now

Thank you, Rahul. Appreciate your time.

Hi Rahul,
I was able to work my way through the assignment and now I have difficulty with the Get Attribute part where I’m experiencing issues with the selector. Here’s the full error message:
An ExceptionDetail,
likely created by IncludeExceptionDetailInFaults=true,
whose value is:
UiPath.Core.SelectorNotFoundException: Cannot find the UI element corresponding to this selector: ----> System.Runtime.InteropServices.COMException: Cannot find the UI element corresponding to this selector:
at UiPath.UiNodeClass.FindFirst(UiFindScope scope,
String nodeID)
at UiPath.Core.UiElement.FindFirst(FindScope scope,
Selector selector)
— End of inner ExceptionDetail stack trace —
at System.Activities.Statements.Throw.Execute(CodeActivityContext context)
at System.Activities.CodeActivity.InternalExecute(ActivityInstance instance,
ActivityExecutor executor,
BookmarkManager bookmarkManager)
at System.Activities.ActivityInstance.Execute(ActivityExecutor executor,
BookmarkManager bookmarkManager)
at System.Activities.Runtime.ActivityExecutor.ExecuteActivityWorkItem.ExecuteBody(ActivityExecutor executor,
BookmarkManager bookmarkManager,
Location resultLocation)

Thanks in advance.

The exception says your selector for “Get attribute” is not valid.
Re-select the activity and see if it works or post the screenshot of selector and the properties for the activity.

its actually a popup not an ui element to have selector use screen scraping to extract the hash value

I got past the Get Attribute. The part where i extract the confirmation id after uploading yearly report is proving tricky.

I think the part where you extract the information is from a pop-up.
So you need to attach another window and then use get text activity to extract information.

i used screen scarping so it automatically give you attach window still i need to add another one?

I’d suggest that you manually attach the pop-up window and use get text activity to capture the value.

Thanks, Rahul