Level 3 Advanced Training Assignment 1 - Calculate Client Security Hash - Cannot find UI Element

Please ensure TransactionData is not null at this stage.

I think you are assigning the result of dataScraping into TransactionData. Ensure the arguments are mapped correctly from the invoked workflows.

Hi @gulab

I tried this:


And it still didn’t work. :frowning:

Regards,
Mc

Hi, @SowmyaLeo, @gulab,

I think I know the problem now:
It seems that the bot is already closing the application before attaching the close sequence:
image
I’m assuming the bot is closing it because it already encountered an error, can you guys help me debug this?

Regards,
Mc

@UiP_Mc
The issue is here:

Extract_WorkItems
The dataTable is extracted into the ExtractDataTable variable, but this has not been assigned to dt_WorkItems output argument, so when dt_WorkItems is mapped with TransactionData it is set to null.

Solution:
Please change ExtractDataTable to dt_WorkItems and try.

1 Like

It finally worked, thanks @SowmyaLeo!

1 Like

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.