Level 3 Advanced Training Assignment 1 Attach Browser

Hi, I am stuck on Assignment 1 of the Advanced training. When I try to run my main workflow an error occurs when trying to close the system1 browser. I have read other posts and changed the selector using wildcards but I am still getting an error. Anyone know how to solve this?

The thing is, your workflow trying to close the browser before even opening it @heerenj4 as per your outpit panel

Are you using Close Tab Activity inside Attach Browser activity?

When something like this happens, I usually put that part into the _Test xaml file and test it manually.
I would suggest opening the last page you were in, putting Attach Browser activity and testing your selector

@HareeshMR any idea why this would be happening and how to fix it?

@srdjan.suc I think the selector is fine. When I run just the Close System1 workflow, it seems to work fine.


I am also trying to upload my project file for you guys to see, but since I am a new user, it won’t let me attach any files.

You can’t upload xaml file or the whole zip?

Main.xaml (54.1 KB) System1_Close.xaml (6.4 KB)

Letting me do it now I guess. Attached is my main project workflow and the System1 Close workflow that has the the selector issue

@srdjan.suc were you able to access the files attached above?

1 Like

Maybe it would be better for you to upload whole zip file so I can inspect the whole workflow.
Let me check this out

So just this flow works.
Something else might be the problem.
Did you correctly invoke this workflow within “Close Application” part?

AdvancedAssignment1.zip (514.2 KB)

@srdjan.suc I am not sure if I invoked it correctly. I think the issue that @HareeshMR mentioned earlier in this thread is my issue and that the close system1 workflow is happening too soon but I am not sure how to fix it. I have attached the zip file to my project. Any help or hints would be great. Thanks!

1 Like

Sure, I’ll take a look at it. Sorry for long response :slight_smile:

Meanwhile i would remove the part where you Logout of the application and just try to close the tab

Hi @srdjan.suc I was able to work around this issue, and now I am another problem. Instead of assigning a hash to each processed transaction, I keep getting the error in the screenshot below and it seems like each transaction item is being set to when I log into the System1 site instead of iterating through each WI5 work item. I have also attached the project for your reference. Thanks!

AdvancedAssignment1 (2).zip (513.8 KB)

Try changing key values in your Config.xlsx file not to have spaces.
From System 1 URL to System1_URL something like that.

Also, I cannot see the part where you actually access Work Items and scrape the values?

Also update your Config.xlsx file to contain the key. Current one does not have.

In one workflow is System 1 Url and in other is System1_URL please fix this

The workitems are being scraped in the “Extract_WorkItems” workflow in the system1 folder

and I will makes the updates in the config file and let you know if this fixes the issue. thanks!

@srdjan.suc fixing the config file and updating my key values solved my problem! my file works now.thanks for you help

1 Like

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.