Level 3 Advanced RPA Developer Assignment 1- Error when running the main file

studio

#1

Hello everyone ,
I have attached my assignment . Can someone check and let me know where i am going wrong . When i run the Main workflow , i get the error as below
image

ReFrameWork-Assignment1.zip (1.7 MB)


#2

reason is you have missed the binding of the variables in the invokes and thus the url for pen browser is empty

And its for all the invokes which have arguments you need to do the mapping.


#3

Hello Nadim ,

Could you tell me how do i do that please. Is it that we have to create a variable and store it in the default value field .

Thanks in advance


#4

Not really. if you follow the steps in the pdf it explains how to do this.


#5

Okay … I was able to launch the browser successfully . I have the next issue
I have used Asset
Asset name : in_System1Credential
Where i have entered the user name and password for the url
I have used same name in the config file “in_System1Credential” and given the value as “in_System1Credential”

Now I have used get asset and get credential activity in getappcredential.xaml file

When i run the workflow , i get error as
Type Secure Text push button: Value cannot be null
Parameter name :securePassword

I am a litte confused as why the variable is not storing the information that i used in the asset

Could you give me some suggestion

Thank you


#6

In the TypeSecureText activity the password varibale goes in the properties pane and please make sure you are getting back the details from getAppCredentials.
Have you done the variable binding for that invoke?


#7

Hello Nadim ,

I did something … Couldnt understand . Now again i am stuck in launching the website . :frowning:


#8

your url is not mapped in the invoke or missing in your config.


#9

Hello Nadim ,


#10

need to see your invoke of AcmeSys1 login and also let me know how you are testing?


#11

Attached the login workflow file System1_Login Workflow.xaml (16.0 KB)

in the open browser field , i entered an argument “system1_url” and gave the default value as “Data\Config.xlsx”
I think this is where i am going wrong. I am not sure what to use in the default value :frowning:


#12

Hello Nadim ,

Have you had some time to look into the xaml file that I attached .

Thank you


#13

Hi, Yes i had a look and the process is wrong
First, you dont have to call InitAllsetting inside your Login workflow. Only getAppCredentials.xaml you need to invoke(which you have done)
The argument in the invoke getAppCredentials has to mapped to a local variable.

Default value for system1_url will be the acme url https://acme-test.com

Suggestion: follow the pdf step by step as you have missed some steps.


#14

thank you Nadim . I have one question . when I have already put the url in the config file , why do i have to set the default value as "https://acme-test.uipath.com " in the argument.

I made the changes as you said .
Removed initallsetting file
I set the default url in the argument
I mapped the argument to a local variable
Still i get an error saying
Source :Type secure text input password
Parameter : Value cannot be nullSystem1_Login Workflow.xaml (15.0 KB)


#15

Ok, before i go to the next error, the reason i asked you to set default value was because you were testing the the login flow independently. If you are testing the whole flow from Main then your input argument will have an entry from the config file when you pass the value like that.

Also you cannot set default value as “Data\Config.xlsx" as that is a path.

Same reason i suggested that you follow the steps line to line in the pdf.

for the second issue, its because the type Secure Text activity you have not passed the password property. Add that and this issue should get resolved :slight_smile:


#16

Thank you for your help … Ill try to do it .