Lesson 1 - Introduction to UiPath - System.ServiceModel.EndpointNotFoundException is thrown

studio
exception

#1

Scenario:

UiPath throws a System.ServiceModel.EndpointNotFoundException error when I hit the ‘Run’ button and ask it to fill out a simple form.

Steps to reproduce:

Following Lesson 1 - Introduction to UiPath on the RPA Academy. I use UiPath to record myself filling in the AnyTeller form and hit the accept button. When I hit ‘Run’ in UiPath I receive an error. Please follow up to 5 minutes into this video.

The top line of the error is:

System.AggregateException: One or more errors occurred. ---> System.ServiceModel.EndpointNotFoundException: There was no endpoint listening at net.pipe://localhost/UiPath/service/duplex/agent/OliMorris that could accept the message. This is often caused by an incorrect address or SOAP action. See InnerException, if present, for more details.

Please see this Gist for the full error:

Current Behavior:

Throws an error.

Expected Behavior:

Fills in form of the Any Teller application

Studio/Robot/Orchestrator Version:

Studio 2017.1.6522

OS Version: Windows 10 Pro 64 bit .NET 4.0.30319.42000


#2

Hi Barry,

Do the suggestions in this post help?


#3

Hi @ovi .

Thanks for the suggestions. I followed the instructions, restarted, and it’s throwing the same error.

I do have BitDefender 2018 installed but after I disabled everything, the same issues were happening.

Thanks


#4

Do you have Community Edition? Did you also try uninstall and reinstall?


#5

@ovi yep it’s the community edition. Uninstalled and reinstalled. Still no luck.


#6

Seems like Studio cannot connect with the Robot. What if you open Robot tray from %localappdata%\UiPath\app-17.1.6522\UiRobot.exe, then publish locally and start the process from tray?


#7

@ovi Great idea. Weirdly…when I do that and open up UiRobot, I see “Error connecting to Ui Robot Service”

Following the advice you gave here… I’m unable to get it to work.

I should say that I had UiPath Studio working last week with no problems. It’s ever since I downgraded to UiPath Studio Community that I have the issue. I note that I did a complete uninstall before I installed the Community edition.

This is proving to be super challenging!


#8

So you’ve had the trial before? Did you have the .msi before and now the .exe?


#9

I had the trial before. Yep it worked like a charm - no issues with it.

I did update Windows 10 on between changing versions but I don’t know of anything they changed which might have scuppered things. Any idea?


#10

@ovi are there any known issues with switching from the trial to community? I see a lot of issues on the forum about these types of errors and none have marked solutions.


#11

Hi Barry,

The thing is if you had the trial version, therefore a license code, you cannot go back to Community version(regardless of the installer).

As it is stated on UiPath website, the free Community Edition is “Free to use in academia, nonprofits and small businesses with an annual turnover of less than $1 million or 250 workstations.” So, if you’ve requested trial, that means you(as a customer) don’t fit in the Terms and Conditions for using the Community Edition.

What you can do after the trial expires is to request the extend of trial or buy the Enterprise version. You can do the request here: https://www.uipath.com/contact-technical-and-activations - select Service request -> Licensing


#12

I am having the same problem as Barry, but unlike Barry, I never used the trial version. I just installed the community edition, and when I run the automation from the studio, I get “EndpointNotFoundException”. I am running Windows 10 Home Edition. Any suggestions on troubleshooting?