Json update from Excel data

Yes the datatable what we used is different from what I gave… The Keys in dtable1 are unique.
The previous error is the same what I am getting.
Seems to be issue with the defined dictionary.
Does it have anything to do with the fact for few of keys in dtable,the values are simply whitespace or null.?

yes can be a hint / trigger when it is affecting the keys

So how do we avoid it and proceed further… Because those values are needed to be blank?

distinct / filter strategies. Maybe you can share the Excel / datatable content with us

Please see the datatable

lets try to progess with a minimal ping-pong round.

Just confirm:

the shown datatatble is the variable: dtable1 and same content is used for LookUp Dictionary

if so, save all xamls and check all import argument definitions including the argument-variable wirings

Am actually not sure where exactly is the error. This is the first time am working on such scenario so don’t have much idea about it. I shared the error previously that is the same error what am getting.
XAML is not involved in Invoke Workflow.

This is the datatable mapping for the same… Please check if the nested keys are given correctly?

in such a case you can debug and inspect the details

also have a look here:

As also mentioned a few times. You can share your XAML with us, so we can review

The xaml is official purpose, I won’t be able to share it. Itried few modifications and now am not getting the error but now I get error invoke method: Value cannot be null.
Any suggestions for this ?

Debugging will help. Also have a check on the provided link from above
you can do following:

  • set a breakpoint

  • debug file and get paused

  • open immediate panel and type in:
    row(“Path”) - confirm with enter
    get feedback which path is used

  • type in myJObject.SelectToken(row(“Path”).toString)

  • in case of it is returning null the item cannot be found within the JSON for the provided path

Once it is identified, then fix the Path info

Yes I tried that but I get the below error.

show us the variable setting of the variable returned from deserialize JSON and also show us, where the breakpoint was set and the debug was paused

The Breakpoint is set at Invoke Method.
Am not getting error as previous for row("Path) or myJObject but still getting the error that the given key was not present in the dictionary. All the keys of the datatable are picked up till the end and the error pops up at the end.

all you can check now, while debugging and it can be analyzed which key is failing

It has taken all the values which we gave in the datatable . Even then the error is popping up after the process…Do we need to do any other action to solve this ?

Also I just typed in Immediate myJObject.SelectToken(row(“Path”).ToString) is giving JArray(0){}.
Is this causing the issue?

let us summarize what we achieved so far

  • we gave you a working Demo XAML implementing your case
  • you did some modifications and do face some issues
  • as we only have partly knowledge of the now implemented XAML(s) from your end and you cannot share it, we are limited
  • the reported issues can be analyzed while debugging and e.g. checking within the different debug panels
  • we also shared help / video for this with you

Have a look on the Debugging course from the Academy

this will train you and will help you to do some further analysis on your end more independently. When you do face again issues after the training and driving the analysis steps we will still support you

I am actually in a time constraint and there’s deadline because of which I am hurrying up on this…
Thanks a lot for all the information shared with me which guided me with the process.

Although,Am trying to figure out why am I getting (The given key was not present in the dictionary JArray(0){} ) even though it had actually processed all the rows and respective values which I gave in the datatable.

I could successfully implement it.
I just have one more question how do we go upon writing this json object into a notepad or a json file ?