Jobs are in Pending State

Hi, I am trying to execute the process in Orchestrator, But in the ‘Jobs’ Section all Processes are in Pending State.
When I am executing the processes from UiPath Assistant, it is working properly, But when I am trying to Start a job from Orchestrator it is going in a pending state. Can anyone guide me on this?

And it also shows ‘Host Identity’ in ‘Pending allocation’.
1)How to allocate the Host identity? (Where can I find it)
2)Where I change Service attended and Unattended in Job Type


Did you creat an unattended bot?

And assigned the license ?

Installed the robot in service mode?


Thanks for your Reply, But
Already Unattended bot created and assigned the License
robot is in Service mode. Still showing “Pending Allocation”?

Where i can get Host Identity?


Can you try clicking on start job and check if you are able to see a user and machine from dropdown and select them and run please

Once you select machine you can choose hostname


Hi @AmlanKiranPatel

  1. Make sure you have the necessary robots available in your Orchestrator. Go to the Robots page and ensure that there are robots listed and they are in the available state. If there are no available robots, you might need to provision or allocate additional ones.
  2. Check the robot capacity: Each robot has a capacity that determines how many processes it can handle simultaneously. If the available robots are already at full capacity, new jobs will go into a pending state. You can adjust the capacity of a robot by editing its settings in Orchestrator.

Regarding host identity, To allocate the Host Identity, you need to ensure that you have configured a robot and connected it to Orchestrator. During the robot configuration process, you will need to provide the machine key and Orchestrator URL to establish the connection between the robot and Orchestrator. Once the robot is connected, it will have a unique identity (Host Identity) associated with it in Orchestrator.

To change the job type, you need to configure the robot accordingly. In Orchestrator, go to the Robots page, select the robot you want to modify, and edit its settings. There, you can specify whether it should be an attended or unattended robot.


Hi, I did as you suggest,1 Problem is solved. But still, there is an issue with “Pending”.


Did you provide the credentials in orchestrator?

And is the machine you are assigning shown as available? Or is it offline


Hi @Nitya1
Here, How to know if Robots are in available state or not? & How to check Robot Capacity?

Hi @Anil_G
Machine is available. and Credential means this one


No…go to manage access page …

And there go to the user who you are selecting …click on edit and on third page it would ask for password and udername provide them


Ok Got it. But Which ‘UserName’ & ‘Password’ do I have to give?


Which ever machine you gave as unattended bot…that machien credentials to login…

For username type whoamin on that vm or computer in cmd

And password is the windows login pssword


Done. But still the process is in pending state.

I think the problem is with the Robot?


Is the servicehost running on the robot?

Is it available at all?

Can you tell about your setup and what machine etc



Servicehost??? Can you Explain littlebit.


Can you please tell about your setup

That is a service which you can find from
Task manager in your target system where you want to run


‘UiPath User Service’ is running in Task Manager.
I am Working on my personal laptop

1 robot with my login mail name.
connected with assistant(Service URL)

It was working properly before 4-5 days. but I don’t know what happened. it is always showing the status in the pending state.



Is it community version?

If yes…then first we have only one production license…the other machine which is there might be consuming it…

Can you assign production to only one machine please

Also please validate setup with the link provided at the first …just toverify because without credentials ideally from Orchestrator it would not run