Job stopped with an unexpected exit code: 0xE0434352 when uploading Queue items

I am uploading bulk of queue items to Orchestrator using Bulk Add Queue Items activity. Initially it uploads the items but after sometimes terminates with an error: Job stopped with an unexpected exit code: 0xE0434352. Please can anybody help me how to resolve this??

Thanks!

Please check this…!

I tried this but no effect. Please suggest another solution if somebody has!

Thanks!

1 Like

I am also having the same problem, I tried above solutions, any one has a solution on that,

2 Likes

I’m still having the issue. Please some other suggestions, if any!
Thanks so much!

Moreover I have the same issue when I put my workflow in Process.xaml file under Process Transaction part of REFramework. When I start the process, the process executes for sometime but after that it shows this error.

Please help if somebody have some suggestions on this!

@Hassan_Ali

Create one workbook variable for Excel application scope activity and then use Close workbook activity and pass that workbook variable to close the excel file and this activity should be after Excel application scope activity.

As mentioned above, this was already tried and found not to be a solution to the problem. Please do not answer the question by restating ineffective solutions.

I am having this issue as well and do not interact with excel at all.

I have also tried limiting the size of the datatable that is being uploaded to the database in my workflow. This is especially difficult to handle as this error does not throw an exception. I do not think there are other variables that are exceedingly large in terms of memory.

Browser variables are also being passed between workflows in my workflow. I have also seen this proposed as the cause of the issue.

Some other reading here has indicated to me that this may be the executor taking more ram than is allocated to the executor. Are there some ways to clear the memory used by the executor in the middle of the workflow maybe?

1 Like

I have found some further information. In my particular application I am dealing with large lists of dictionaries of UiElements, and I believe that these are taking up more RAM than is allowed by the 64 bit Windows (in my case) OS. This is due to the robot being a 32 bit application, and as such is only allowed 2GB per user of RAM.

I believe this is the case because after the appearance of this error, checking task manager showed the UiExector to have consumed nearly 2GB of ram, which can result in overflows and crashing.

The best explanation of this issue I’ve found so far is in the Microsoft documentation here, although this is an article to enabling page address extension, which is only applicable to 32-bit operating systems. Check here for your particular OS version to learn more about allocating additional RAM to the UiPath Executor.

I will be looking into the IMAGE_FILE_LARGE_ADDRESS_AWARE flag as mentioned in a related technet conversation and will update this depending on the results.

Can’t wait for the executor to become 64-bit so we can be limited by our hardware and not 32-bit address space.

EDIT: Would not recommend attempting to set the LARGE ADDRESS AWARE flag at time of calling. dumpbin doesn’t show further information indicating whethere LAA is enabled or not either. Editbin would probably violate the ToS as that could be seen as modification of the source code. I don’t want to go further down that rabbit hole of checking all dll headers and trying to set that flag.

Another option could be some 3rd party programs designed to set that flag used by retro pc gamers, but again getting into iffy legal territory.

Instead going to be looking for a way to internally limit certain data structure sizes within the code. Would be nice if, when this crashed in this way, UiPath was able to detect which variables were taking up the most memory.

1 Like

@tjsauter - hopefully your have resolved this issue.

This is for any who comes looking for a “potential” solution.
In my scenario, I was reading an excel with range set to “A:AJ”.
The bot began to read the excel, but somewhere in between threw this mentioned error.
I set the range to “” in read range (instead of “A:AJ”) and the bot functions successfully now.

Can you help me to identify which variable is taking most memory. We are also facing the same issue with long running processes. We suspect the issue is with a Browser variable but not sure

i am also facing the same issue. i have not given any range in read range activity, instead i have given “”. I have huge data(A:BH) columns and (4000-3000)rows.
still iam getting the error “System.Exception: Job stopped with an unexpected exit code: 0xE0434352”.
Is there any other solution for this kind of issues.