Job run did not end the process even after setting "stop after" to "next 30 min"

I tried scheduling a job run but had to disable it as it did not stop after 30 min of execution(snapshot below) :frowning:

Make sure you have selected kill job in the actions tab @new_user

I think it was set to “kill” but i’ll trigger it again and confirm. :slight_smile:

it did not stop on selecting :image


expected: it should have ended after 30 min but it didn’t

Are you using stop job or disable schedule?

If it is Stop job , using kill will the job.
Actually for stopping the jobs execution, use disable schedule option and provide the required time to run and check. This should work

i’m using stop! trying disable now…what does stop do then?

also, what is the time format (am/pm) or (sec/min,etc)reflecting here?

In stop, if you are using stop in the actions tab, it will stop the job whenever it comes across should stop activity in the workflow, otherwise it won’t stop. Kill should forcefully stop the schedule. But I’m confused why it is not working in your case…
Here is the reference documentation:

i’m facing this error however i’m entering later date

04 it will take as AM,

give it as 16 @new_user

TRIED again using kill and it did not stop:
image it shouldn’t be working after 4pm(i.e. 16) :frowning: isn’t it a major bug?.

Can you please try with disable schedule after?

Will get back to you learning more about stop job :slight_smile:

the above one was tried using “disable” and kill! many thanks!

Still it wont stop !

this is strange!

Any update on this? Are you having SMTP activities in the workflow as in below article?

could the role provision be the issue here?