Job is getting failed only for newly added unattended robot -Cannot create unknown type

All of our processes have been developed with UiPath studio version 20.10.4 and its been running smoothly in production almost a year.
Now ,I need to add a new unattended bot with the newly created VM.
I installed UiPath robot 20.10.4 inside the new vm and connected this bot with orchestrator as well. However ,when i try to run the process in unattended mode , job gets triggered and faults in few seconds , error message is cannot create unknown type ‘{}shouldStop’.

I tried installing unattended robot 20.10.4 , 21.5 and even some other near higher and lower versions ,still this issue persists.

I am working with 21.5 studio version in dev machine without any issues on these processes and published many enhancements works into production which is having robot version of 20.10.4 Why is this new bot is getting faulted with this error?

The Should Stop activity is an activity from the UiPath.System.Activities package. This means, in your impacted robot, the required UiPath.System.Activities package version was not installed correctly or was not installed at all.


You can go to the %userprofile%\.nuget\packages folder → delete the UiPath.system.activities folder and retry to install the process in the impacted robot machine by running the job one more time.

1 Like

Hi @sathiswaran.p1992 ,
I think , this error is caused by lack of Activities package. It fails if the robot is closed network or setting of proxy is not good etc.
If the robot can access UiPath official feed in the internet, it will be automatically downloaded.
you can try
Copy all the folder in %USERPROFILE%.nuget\packages from PC of Studio to PC of Robot.
Install “local activity feed” to robot using installer if not in previous.
Fix proxy settings if it can access to the internet.

1 Like

Hi Marian,

Thanks for your reply

Did the same by deleting and restarting the process but still the same issue persists

Open the process in Studio with the impacted robot and check if you still have the error.

tried connecting studio with unattended robot , it says package installation failure

What source you are using for the Official feed?
What errors you are facing while trying to install the Microsoft.Activities package?

Its Official feed actually ,

I am working on coping all the packages from working VM into the impacted bot as the official feed has been blocked itseems

Is the any way how we can find the official feed is blocked or not to get the help from IT helpdesk team

You need to close any UiPath Studio windows, go to C:\Program Files\UiPath\Studio\NuGet.config, and change the value of the Official feed from to

After, save the file as Administrator and restart Studio.

Starting with Studio/Robot/Assitant 2022.10, the new Official feed is set to


1 Like

Thanks a lot Marian Paltonov ,

It works by changing the recent Official feed URL

You saved my time else i would go with coping all the packages into New VM

1 Like

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.