JIT Compilation is disabled

Invoke Workflow File: JIT compilation is disabled for non-Legacy projects. ExpressionToCompile { Code = CurrentRow(“Security name”).ToString.ToLower.Split(" “.ToCharArray)(0).Trim.ToLower.Contains(in_str_FileName.Trim.ToLower) And Math.Ceiling(Convert.ToDouble(CurrentRow(“Claimed tax”).ToString.Trim.Replace(“,”, “.”))) =Math.Ceiling(Convert.ToDouble(in_str_AmountFromPortal.Trim.Replace(“.”, “”).Replace(“,”, “.”))), ImportedNamespaces = System.Collections.Generic.HashSet1[System.String], VariableTypeGetter = System.Func2[System.String,System.Type], LambdaReturnType = System.Boolean } should have been compiled by the Studio Compiler.

I’m getting this error while running the process from assistant only. same Process was running sucessfully from studio.
@Anil_G @Yoichi @mohiniganesh15 @Kalpesh_Chaudhari @Sudharsan_Ka o you have any idea guys?
I tried all other solutions mentioned in other similar post like updating/downgrading packages


Hope the below thread can resolve your issue:



I tried this one also but still same error comes

why this error occurs? Due to package or anything else?

Hi @nisargkadam23 do you have any idea about this?


Try these

  1. Remove project.json and reopen
  2. Try downgrading packages to new 21.* system and ui activities as well
  3. I hope you migrated from legacy to windows…if yes…check if you have used any powershell scripts then re add them and the activities…

This is basically because of dependancy differences and activity differences…so try looking from that perspective

Hope this helps


1 Like

Yes few days back migrated from legacy to windows. I used vba script in this process is it also creates this problem


Try then…try removing them and re add or before adding check if you are getting issue…I know its is issue for power shell not sure of invoke vba…

As of now we know that it is because of activity changes but not more data like what all are creating issue…


1 Like

not working


Are your robot and studio are of same or compatible versions?

And also check any legacy activities you would have used to see if there are changes …try adding the latest activity alternatives for them…


Robot and studio are of same versions

This error has been fixed now, By rewriting syntax. There was a problem in syntax for double quote symbol

1 Like

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.