Jenkins & Uipath orchestrator Integration

Hi all,
Good Evening, Hope all are well and safe.

I was trying out the CICD (Continuous integration & Continuous Development) pipeline using the Uipath-Github-Jenkins-UipathOrchestrator.
My plan was when I updated the package in GitHub through the studio, the Jenkins should update the same version in the Uipath Orchestrator of the respective process. Integration between the first 3 tools (i.e…, Uipath Studio-GitHub-Jenkins) was successful,

I am able to see the new build in Jenkins which I updated in the Github, but the problem is occurring between Jenkins and Orchestrator. In the Jenkins Build output console, I am getting the below error

Started by an SCM change
Running as SYSTEM
Building in workspace C:\WINDOWS\system32\config\systemprofile\AppData\Local\Jenkins.jenkins\workspace\JenkinsToGit_First
The recommended git tool is: NONE
No credentials specified

C:\Program Files\Git\bin\git.exe rev-parse --is-inside-work-tree # timeout=10
Fetching changes from the remote Git repository
C:\Program Files\Git\bin\git.exe config remote.origin.url GitHub - Csathwikreddy/JenkinsUipath_TestRep: Versions Test # timeout=10
Fetching upstream changes from GitHub - Csathwikreddy/JenkinsUipath_TestRep: Versions Test
C:\Program Files\Git\bin\git.exe --version # timeout=10
git --version # ‘git version’
C:\Program Files\Git\bin\git.exe fetch --tags --force --progress – GitHub - Csathwikreddy/JenkinsUipath_TestRep: Versions Test +refs/heads/:refs/remotes/origin/ # timeout=10
C:\Program Files\Git\bin\git.exe rev-parse “refs/remotes/origin/master^{commit}” # timeout=10
C:\Program Files\Git\bin\git.exe rev-parse “refs/remotes/origin/origin/master^{commit}” # timeout=10
Checking out Revision 848e9a1a144ec29f2b0003d23da247b9e90b5feb (refs/remotes/origin/master)
C:\Program Files\Git\bin\git.exe config core.sparsecheckout # timeout=10
C:\Program Files\Git\bin\git.exe checkout -f 848e9a1a144ec29f2b0003d23da247b9e90b5feb # timeout=10
Commit message: “version 1.4”
C:\Program Files\Git\bin\git.exe rev-list --no-walk 90b864f22086cb0c21ea52e1f184b6d7dfa2c4ce # timeout=10
Expected plugin jar path on Jenkins master: C:\WINDOWS\system32\config\systemprofile\AppData\Local\Jenkins.jenkins\plugins\uipath-automation-package\WEB-INF\lib\uipath-automation-package.jar, extracting…
Extracting cli to temp folder C:\WINDOWS\system32\config\systemprofile\AppData\Local\Jenkins.jenkins\workspace\JenkinsToGit_First@tmp…done!
[net461] $ C:\WINDOWS\system32\config\systemprofile\AppData\Local\Jenkins.jenkins\workspace\JenkinsToGit_First@tmp\cli-1.0.7513.25211\lib\net461\uipcli.exe run C:\WINDOWS\system32\config\systemprofile\AppData\Local\Jenkins.jenkins\workspace\JenkinsToGit_First@tmp\uipcliargs4367190460241292032
ERROR: Step ‘UiPath Run tests’ failed: Failed to run the command
Finished: FAILURE

Kindly let me know if you have any suggestions to make the CICD pipeline work.

Thanks & Regards,
Sathwik Reddy.

Hi @Chinthala_Sathwik_Reddy,

It looks like there was a non-descriptive internal error, potentially due to the workspace path that you are using.

Consider using a Jenkins workspace path outside of C:\WINDOWS\, as this may lead to issues.

Hi @AlvinStanescu,

Thanks for your response. Could please elaborate on the issue. Following is the Build configuration of Jenkins with Orchestrator, can you please check it and let me know what is the path which we had to mention in the below screen,

Build Screenshot

Pre-build Screenshot

Can you please check the configuration and me weather i am on the rigth path or i gave the wrong info in the fields, cause i have tried giving different paths but it was failing every time with the bit similar error.

Thanks & Regards,

It seems that you’re trying to use paths outside of the workspace folder, which is not supported and is discouraged in Jenkins anyway, since a CI/CD build should never write to external paths (nor ideally read).

Please use workspace paths, e.g. ${WORKSPACE}\MyTestingProcess (or simply MyTestingProcess, since by default all paths are relative to the workspace folder).

1 Like

okay, i will try that. Thanks Alvin. Do you have any docs are videos on the configuration part Alvin, That would really help us a lot.

The current documentation can be found here and an introduction to CI/CD integration with Jenkins can be found here.


Thanks you so much Alvin, I really appreciate your time and effort spend on answering this.
Thanks a lot and have a grate day.

New Updated Jenkins Plugin works well . I have recently tried implementing CI CD using Jenkins Plugin and it works like charm.

In case you wih to have a look at the codebase you can follow my step by step guide here

I am getting the below error building with jenkins,

Below are config details,

I have used the output folder path as mention by Alvin.

Can you let know what is the issue on this ?


was jenkins installed directly on your orch server or do you have a separate jenkins install/server dedicated?

I faced a similar issue recently. Declaring the GIT tool in Jenkins slave configuration helped me. Checkout details here: git - ERROR: Error cloning remote repo 'origin' - Stack Overflow