Java: Menu Item not selected

Hi Experts,

I have a menu where I want to select the action: “New” from the dropdown box.

I’m unable to get UI Explorer to open this. I’ve tried using the up key 3 times (when I do this myself it works).

This is the menu:

This is my activity:

What am I doing wrong?

Thank you!
Memre

try with the option ClickBeforeTyping checked in the properties panel and then tell us if that works for you.

Thank you Carmen,

I made the change and then the up arrow only goes up to the entry below ‘New’.

I then get this error:

Hi @memrevh

Could you try Send Hotkey activity instead?

Hi @loginerror,

The problem is I don’t know how to send a hotkey for the up arrow x 3! :blush:

So what I need to do is the following:
up arrow x 3 + enter + enter

if you can possibly guide me I would really appreciate it! Thank you!

instead up … you could try with home

1 Like

Maybe a bit messy, but something like that:

Thank you @Carmen. This worked very well!

2 Likes

Thank you @loginerror for the assistance. The ‘home’ button worked! :grinning:

1 Like

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.