Issues with workbook full name

studio

#1

Hi !

I have a issues with this macro, send me this message!!
“Write WorkbookFullName to run macro in : The range does not exist”

issuesmacroissuesmacro01

I need your help for a solve this.

Thanks :slight_smile:


#2

The error is generated from 1st activity in the screenshot. try to write line the range specified and see if it exists.

I see “workbook…” is specified in the range which is incorrect format. It should be like A1,B1 etc.

Similarly check for 2nd activity as well.


#3

Well, the same project it is works but when can I try use in another package or path this not works, and send me that message.


#4

sorry didn’t quite get it.
What do you mean by another packages?
anyways why there is write range(workbook) activity inside excel application scope,you should have used write range (excel).


#5

I have the same example in another path and it works, when it next to the project sends me that mistake and it is the same project only with different path.


#6

I already solved the above, it is works :slight_smile:
But now I have a new issue : Read Range : A column named ‘1’ already belongs to this DataTable. try with range “A2” and “”, but not works, does anyone have any suggestions for this?

issue2

issu3


#7

Check the columns of your excel sheet. Looks like the column names are duplicated.Read range does not accept duplicate column names, you could uncheck ADD HEADERS to make it work.


#8

I think your DataTable column name has duplicate Value…
Which means your DataTable column has Same name like ‘1’…


#9

I did what you suggested, and the result of txt is the following:

Row1Txt: Columns1, Colunm2, Column3
Row2Txt: Code, FirstName, LastName, Age
Row3Txt: 12345, Juan, Perez, 23
Row4Txt: 54321, Oscar, Benitez, 67

What I try to say is that I do not delete the headers but it add a row of more.

what other query can I do to remove the headers?


#10

Can you share your excel that you are having issue with. Someone will be able to provide the code.


#11

This is the example!!

example.zip (24.5 KB)


#12

Hey @SCOVARRU,

Try to activate Add Headers option in Read Range activity

image

Regards,
Susana


#13

Thanks Susana :slight_smile: , but I need to remove the first row like a column name, uncheck the box “AddHeaders” but not is good solution and I try with remove data row index 0 but remove the next row to column name. How can I have it remove the headers?


#14

Hello @SCOVARRU,

Please try with this example_2.zip (24.9 KB)

example

Regards,
Susana


#15

Hello!

Try this:

Worked for me here!

Hope It Helps!

Regards,