Issues with Robot Version 21.10.3 and Background Processes

Hi Community,

We are currently running robot version 20.4.5 and last night I attempted to upgrade to 21.10.3. The upgrade was successful and everything was running and the Orchestrator could see all the robots.

We run a HD setup where a single Windows Terminal Server hosts all the robots and this has worked perfectly for the 3 years we have been running UiPath.

We also switch all of our processes that do not use UI interactions to Background processes so the majority of them are background processes that run on Unattended bots.

Following the upgrade, all our automations failed to execute. The reason for this was that when they were running, rather than running under the ‘robot user’ account they were running under a user NT AUTHORITY\LOCAL SERVICE.

Previously in 20.4.5, the background processes ran under a robot user, even though they were running in Session 0 and the UiPath documentation indicates that this is exactly what should happen. As a result we have a number of these automations that run out SQL selects and use the robot account to do this. There is no UI interaction so so need for the automation to log in.

With the new version, the automations fail because NT AUTHORITY\LOCAL SERVICE is not an authorised user of the database.

We have had to roll back to 20.4.5 which is working, however we need to understand this issue in order to upgrade. Is anyone able to help? Do we need to be on Modern Folders or something to make sure the Background processes can run under a given user?

1 Like

Also having this issue. did you figure out how to get the background processes to run as a service user?

I am afraid not, however it does look like it’s related to the Process setup but the menu item to do the setup is only available when you use Modern Folders.

I am going to have to install another copy to try and figure it out

Are you able to elaborate a bit - i think i’m already using modern folders so can test something

Sure thing. Please have a look at this screenshot

I have been informed by support that this is where you must configure the setup

My screen looks a little different. Any thoughts?

I already have the “Machine Login credentials” ticked (just disabled for screenshot) but that does not help.

Did you manage to work out what the issue was? I was going to ask you to try with the ‘Machine Login Credentials’ unticked

It is ticked- I just unticked to hide my user/pass. Unfortunately it doesn’t work. Opened a ticket with UiPath but they have not responded.

The only thing I can think of is perhaps we need to not be using the background process option on the automation, which doesn’t reallyt make sense

Starting with the 2021.10 release, running unattended background automations on service-mode robots run by default under the built-in "Local Service” Windows user. Prior to this, the username and password configured for the robot in Orchestrator were used.
To use credentials specified in Orchestrator, you need to configure the UIPATH_HEADLESS_WITH_USER environment variable and set the value to True .
More information can be found in the running background processes document.

Hi @gabriela.lungu

Thankyou for this information. How do we configure this on the Cloud based instance of Orchestrator? Do you know this?

Hi,
Not sure if I understood the question … Can you please give more details?
UIPATH_HEADLESS_WITH_USER is a Windows environment variable set on the Robot machine, not on Orchestrator. Setting it to ‘true’ fixes the reported issue.

Confirmed- this works for me also.

I’m glad UiPath finally updated the documentation (5 days ago) to include this to prevent more customers having to go through this process as support were clueless.

Thankyou very much for your support on this!

Just to confirm this how you setup the Environment Variable on the Robot Server:
Screenshot 2022-01-18 18.26.13

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.