Issues in connecting Robot

This is second time I am having issue to connect using UiRobot. This is happening whenever there is update for UiPath. We got updated to 2019.4.2 - May/02/2019 and I have picked up UiRobot from respective folder (AppData\Local\UiPath\app-19.4.2) to launch and run.
But it is trying to connect on its own without having machine key and orchestrator URL. And always show up “Error connecting to robot service”
I have tried network reset, check UiAgent running using task manager, tried to restart it but it is still not working.
If you see attached image, it will have grayed out connect button and fields like machine key or orchestrator URL. Where you cannot either reconnect or add these values and hence even if you quit that and try to relaunch again, it automatically tries to connect and fails each time.

Hi @vaibhavp2

Try uninstalling UiPath entirely from you computer. Once you uninstall, go to AppData\Local\UiPath\ and delete what is remaining there too.

Then download a fresh installation from uipath studio download site and install it. This might fix the issue…

Let know how it goes…

1 Like

Hi @Lahiru.Fernando,
I tried that Yesterday, and just installed the latest version by deleting everything ( you can see in attached image there is only one folder now for ‘app-19.4.2’. It is still launching with kind of auto-connect with empty information, it is not allowing me to put machine key of orchestrator URL. It is a blocker for me as most of my stuff is in orchestrator and about to configure jobs.


Hi @vaibhavp2

Please try the solutions here:

Please make sure there is no other version of UiPath installed. Have you installed the Enterprise edition before? This one would reside in the Program Files instead of the AppData folder.

1 Like

Hi @loginerror

I have never used Enterprise edition. And I already had 19.4.2 version installed ( deleted all rest of the version folders).
However I was able to get through that issue :slight_smile: The main issue was that in windows “Services” after successful update or if we install latest version directly ( and in case if you happen to have ever installed any of the version probably version 19.1.0) then may be UI Path is not updating that execution path under Windows Services.
So when I did troubleshoot, I found that UiRobotSvc was having following older path “C:\Users\abc\AppData\Local\UiPath\ app-19.1.0 \UiPath.Service.Host.exe” -displayname “UiPath Robot” -servicename “UiRobotSvc” instead of C:\Users\abc\AppData\Local\UiPath\ app-19.4.2 \UiPath.Service.Host.exe" -displayname “UiPath Robot” -servicename “UiRobotSvc”

But Now I am always getting “Task Canceled” as you can see in attached image

Please try to restart your machine, it might fix it

Otherwise, there is a bunch of other threads with solution to the same error message, see here :slight_smile:


I am facing similar issue, can you share the fix
Thank You

Hi Thiviya, please share the exact error you get.
In which part of connecting the robot do you get stuck? What Orchestrator are you connecting to? Onprem? Cloud etc…