Issues getting UIPath to recognize a button to click on

Hey everyone, I’m having an issue getting UIPath to click on a button on a website. I’m getting a SelectorNotFoundException. I’ve tried indicating the selector on screen.

Hello @pjulakanti can you share more information of website and that button ?

@pjulakanti

Could you please post the selector of that click Activity and screenshot of that web page button.

And also at the time of indication is it showed validate in green color or not in under Target section in properties of that click Activity.

Hi buddy @pjulakanti

Welcome to UiPath community buddy

Kindly make sure that property Simulate Click is enabled and this click activity should be inside a attach browser or attach window activity and select the whole webpage abs Element for any of these two activities…
This will work for sure buddy
Kindly try this and let know whether this works or not

Cheers @pjulakanti

@Palaniyappan Does an “Open browser” activity not work in this instance? This is the activity that I’m currently using.

1 Like

yes buddy you can have the click activity inside the open browser itself if you have element to be clicked in the same page when the browser opens with open browser activity…
if the page is different from the page when its opening then we need attach browser buddy and then we need to use click inside that…
Cheers @pjulakanti

@Palaniyappan Ok, I tried to attach browser instead and I’ve run into the same issue. I also tried simulate click like you suggested. I continue to get a “SelectorNotFoundException” for the button. I’ve checked the selector and there does not seem to be any wildcards. I’ve also tried using the “SendWindowsMessages” option. Please let me know if you have any advice. Thanks for the help

@pjulakanti - Try the below approach :

  • Create a new test xaml file.
  • Keep only click activity in it.
  • Open the webpage where you have this button.
  • Indicate the button from click activity. and give a try.
    If this works then in your original workflow try to change “waitforready” property.

If nothing works then please save the webpage as .html and share with us.

@mahesh.kumar Ok, I’ve tried the waitforready options and that has not worked. Interestingly the button press step is not sending an error in runtime, it’s the step after it that’s causing issue. It might mean that UIPath is pressing the button but nothing is happening, however when I press the button it works. I’ve attached the HTML. I cannot share the entire page, so I’ve attached just the section for the button. The button is called “Next”. Thank you in advance.Button

I finally fixed it! For some reason using citrix for button press fixed the issue.

1 Like