Issue with Select Item on Specific Website

I am having an interesting problem with a private website. We had a process successfully running in this site, but the site owner introduced a new pop-up that will show between two necessary steps. This should be easy to resolve, however, it is actually proving quite tricky. Here’s what happens:

  • Select item to pick specific item from drop-down.
  • Pop-up appears on screen that needs to be resolved.
  • Bot produces error Error HRESULT E_FAIL has been returned from a call to a COM component in relation to the select item activity, even though I can visually see item was selected and pop-up therefore appeared

As best I can tell, this new pop-up is causing the bot to think that it has not successfully closed the previous select item activity, even though I can visually see in debugging that the step is complete. I tried to make the previous steps clicks, but when I try to target the specific drop-down item on screen for click activity, I get this pop up:


Any ideas what I can do?

Hi @jcarr79

If I understand correctly the select item is working fine still the bot is throwing an error?

Or is it that the popup is not handled? If the popup is not the select item and just a generic ‘ok’ or ‘cancel’ can you share the popup selectors or screenshot? Have you searched for that element and indicated it?

More details please. :slight_smile:

Sorry, unfortunately needing to be a bit vague for enterprise reasons :slight_smile:

What happens is that I can visually see that the desired item has been selected, and the pop-up appears, which further confirms that the site has registered the item as selected. However, the bot does not actually click in the pop-up, and when UiPath throws the error that I referenced, it says that the error caused the select item to fail. So UiPath thinks the select item failed and therefore does not move on to the next step, even though I can visually validate that the bot did successfully select the item.

I guess the element is not updated which might make the tool think that the select item wasn’t successful.

You can use a parallel activity to check for the popup simultaneously and close it once it appears. Hope this helps


Thank you! That did the trick - running On Element Appear to click the pop-up in a Parallel with the Select Item. Never had to use the Parallel before so I don’t think I would have come up with it on my own.

Glad it worked :slight_smile:

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.