Issue with Read Cell for Excel with Password

Hi I have encountered an error with Read Cell for Excel with password. Previously it was running fine, however, I have encountered the error below. Any reason for the cause?


Source: path_taskkill Read cell

Message: There is an error in XML document (2, 267).

Exception Type: System.InvalidOperationException

An ExceptionDetail, likely created by IncludeExceptionDetailInFaults=true, whose value is:
System.InvalidOperationException: There is an error in XML document (2, 267). ----> System.InvalidOperationException: Instance validation error: ‘SHA1’ is not a valid value for HashAlgorithms.
at Microsoft.Xml.Serialization.GeneratedAssembly.XmlSerializationReaderCT_Encryption.Read3_HashAlgorithms(String s)
at Microsoft.Xml.Serialization.GeneratedAssembly.XmlSerializationReaderCT_Encryption.Read5_CT_KeyData(Boolean isNullable, Boolean checkType)
at Microsoft.Xml.Serialization.GeneratedAssembly.XmlSerializationReaderCT_Encryption.Read8_CT_Encryption(Boolean isNullable, Boolean checkType)
at Microsoft.Xml.Serialization.GeneratedAssembly.XmlSerializationReaderCT_Encryption.Read9_encryption()
— End of inner ExceptionDetail stack trace —
at System.Xml.Serialization.XmlSerializer.Deserialize(XmlReader xmlReader, String encodingStyle, XmlDeserializationEvents events)
at System.Xml.Serialization.XmlSerializer.Deserialize(TextReader textReader)
at UiPath.Excel.Encryption.AgileEncryptionInfo.DeserializeXml[T](String xmlString)
at UiPath.Excel.Encryption.AgileEncryptionInfo.Read(Stream stream)
at UiPath.Excel.Encryption.EncryptionInfoFactory.GetEncryptionInfo(OleStream stream)
at UiPath.Excel.Encryption.OfficeCryptography.DecryptFile(String filePath, String password, Stream outputStream)
at UiPath.Excel.WorkbookFile…ctor(String workbookPath, String password, Boolean createNew)
at UiPath.Excel.Activities.WorkbookActivity1.ConstructWorkbook(String path, String password, Boolean createNew) at UiPath.Excel.Activities.WorkbookActivity1.BeginExecute(AsyncCodeActivityContext context, AsyncCallback callback, Object state)
at System.Activities.AsyncCodeActivity.InternalExecute(ActivityInstance instance, ActivityExecutor executor, BookmarkManager bookmarkManager)
at System.Activities.ActivityInstance.Execute(ActivityExecutor executor, BookmarkManager bookmarkManager)
at System.Activities.Runtime.ActivityExecutor.ExecuteActivityWorkItem.ExecuteBody(ActivityExecutor executor, BookmarkManager bookmarkManager, Location resultLocation)

Hi @Edmundz

We will need more information :slight_smile:

Could you provide answers to the below questions:

  • when did it worked fine? With which package version?
  • what kind of password is it (any special characters?)
  • which package version its not working
  • which Read Cell activity is in use? The workbook one or the Excel Scope

hi @loginerror

It worked fine on Friday 19 Oct 2018 with Community Version 2018.3.1
There are no special characters in the password. There are only alphabets and numbers e.g. abc123
It’s not working in the current package version 2018.3.1 (no changes)
I’m using the workbook one for read cell activity.

is by any chance the excel file build with an older version of excel? like 2010?

@Gabriel_Tatu yes it is built with 2010. Does it make a difference?

yes, the issue is only with these files, you can stay with excel mail version 2.3 until we fix it.

@Gabriel_Tatu Thank you. I will give it a try.

Community 2018.3.2 doesn’t fix this password issue.

Could you try with the newest Mail activity package:

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.