Issue with assigning WIList items in Assignment 3

Hi all,

I’m in the midst of doing the assignment to calculate client security hash but keep encountering the issue with filtering the list of extracted work items and assign it to transaction data.

The code works fine with i’m extracting the data but goes haywire when i tried to use invoke workflow in init.

An ExceptionDetail,
likely created by IncludeExceptionDetailInFaults=true,
whose value is:
System.NullReferenceException: Object reference not set to an instance of an object.
at lambda_method(Closure ,
ActivityContext )
at Microsoft.VisualBasic.Activities.VisualBasicValue1.Execute(CodeActivityContext context) at System.Activities.CodeActivity1.InternalExecuteInResolutionContext(CodeActivityContext context)
at System.Activities.Runtime.ActivityExecutor.ExecuteInResolutionContext[T](ActivityInstance parentInstance,
Activity1 expressionActivity) at System.Activities.InArgument1.TryPopulateValue(LocationEnvironment targetEnvironment,
ActivityInstance activityInstance,
ActivityExecutor executor)
at System.Activities.RuntimeArgument.TryPopulateValue(LocationEnvironment targetEnvironment,
ActivityInstance targetActivityInstance,
ActivityExecutor executor,
Object argumentValueOverride,
Location resultLocation,
Boolean skipFastPath)
at System.Activities.ActivityInstance.InternalTryPopulateArgumentValueOrScheduleExpression(RuntimeArgument argument,
Int32 nextArgumentIndex,
ActivityExecutor executor,
IDictionary2 argumentValueOverrides, Location resultLocation, Boolean isDynamicUpdate) at System.Activities.ActivityInstance.ResolveArguments(ActivityExecutor executor, IDictionary2 argumentValueOverrides,
Location resultLocation,
Int32 startIndex)
at System.Activities.Runtime.ActivityExecutor.ExecuteActivityWorkItem.ExecuteBody(ActivityExecutor executor,
BookmarkManager bookmarkManager,
Location resultLocation)

Screenshots showing the argument and variables of the relevant workflow are as follows:




1 Like

Hi! Please create an output argument in the workflow. I think you have created it as a variable.

Delete the Out_TransactionData variable.

Hi Vasundhara.Sharma,

Thanks for the quick response.

After deleting the out_transaction variable. I encounter the following error:

Seems like the invoke extract data items is not producing the datatable and i’m not sure why.

@ibisan,

Show me your select query.

Pls try below one:

dataTableName.select(“Type = ‘WI5’ AND Status = ‘Open’”). CopyToDataTable

Hi Laskhman,

Tried what you suggested but encounter the same error:

My select query previously was:
dt_ExtractedWorkItems.Select(“[Type]=‘WI5’ And [Status] = ‘Open’”) as i read through some of the other thread that this seem to help some solve their issue.

May I also understand why the suggestion to convert the variable from data array to datatable?

@ibisan,

Are you scrapped data properly or not ?

First try to print all scrapped data without filtering and show me once.

@ibisan,

Where is your scrapped data workflow ?

After System closing workflow, you are trying this ?

Hi ibisan

It seems like you you didn’t do data scraping you just attached the browser, in the Do inside the attach Browser should be your extracted table,


your workflow should look like this

Then below the Attach Browser use the Assign activity like @lakshman explained

2 Likes

Hi Lakshman,

I was able to extracted the data if i run the extract workflow on its own.


The invoke extractworkitems workflow is run in the sequence after killallprocesses in the int file.


You should note that the ExtractDataTable is not created by you but automatically is created when extracting the table from the web

Hi Tshedzamclay,

Yes i am aware.

After some changes, im getting the following error message. Any idea how to rectify?

@ibisan,

Could you please share your workflow file in zip format personally and will check it and let you know.

The problem is where you have placed you Assign, remove you assign activity there like I said before that assign should be below the Attach browser

Thank you.

Did what you suggested but still encountering the same error.

Thanks
Ivy

Please send your workflow so we see what’s wrong

@ibisan,

single quotes are not proper in select query. And also you unchecked Add headers option in Write Range activity.
I modified your workflow as sent to me personally. please find the same there.

Hi @lakshman,

Thanks. I copied and pasted your select statement into my copy but somehow i still encounter the error stating that column WI5 cannot be found.

Please advise why so.

Thanks and regards,
Ivy

@ibisan,

After copy pasted single quotes will change again. Delete single quotes and then add it again.