Issue with Alphanumeric characters - Type into activity with Row("Column1").ToString from CSV

csv
activities

#1

Hi,
I have a csv file from where i should copy and paste all values one by one into an app. For this i’m using For Each activity.

The issue appears when in the csv file gets to an alphanumerical value, please note that the same procedure only for numerical values is working fine.

Can anyone help me, please?

Csv file & type into activity & error:


#2

Hello there,
It’s working fine .
Looks like it’s a validation pop up from web site.
Just to validate its resulting correct value can you indicate on(in TypeInto activity) notepad and run the code .


#3

Hi,
Thank you for your fast answer! You are right, it works with notepad.

But can I do something to fix this issue? I guess the issue appears with the For Each activity because i already have a type into activity(with alphanumerical values) that works in the same page(without For Each) nevertheless it worked even with a hard-coded value in Type Into activity: “23s12” instead of row(“DocumentNumber”).ToString


#4

Oh that bit strange .:thinking:
Try this out.
Use Get row item inside For each row activity which gives you output value in a variable and then use typeinto and pass the variable into it.


#5

Hi,
I did as you advised, but the same issue appears.
Thank you!


#6

@Gabriel_Tatu


#7

Hello @Doru_Ciurar give below a try…

set value to clipboard via Set to Clipboard activity then pass hot key (Cntrl + v) to paste the value.


#8

Hi,
Thank you for your answer.

If i followed the correct steps i have the same issue, and now it’s the same error message even for numerical values.

In notepad it works fine with all kind of values.


#9

Hi Doru,

Since it works with Notepad, my question is, what kind of app are you trying to Type Into?


#10

Hi,

Solved!

The issue was from the web-app because they don’t allow upper case characters.

Thank you for all your answers!


#11

:rofl::+1: