Issue when assigning a datatable into an argument

Hello everyone,

I have an error with an assign activity or merge datatable activity. When I try to assign an existing datatable into an output argument, it’s executed perfectly. But the process stop cause of an error about “Retreiving the result of the task execution”

As you can see below (my UiPath is in english but the error in french, sorry for that…)

image

In english : Can not retrieve the result of the task execution. The message may have been too long to process.

Exception Type: System.Exception

An ExceptionDetail, likely created by IncludeExceptionDetailInFaults=true, whose value is:
System.Exception: Can not retrieve the result of the task execution. The message may have been too long to process.

There is no erros in the logs about it.

The version of UiPath Studio is Enterprise Edition 2019.4.4

The process is basicly, retrieve 2 csv files, merge it and then put the final datatable into an output argument to be used later. The amount of data is less than 35 000 rows with 15 columns.

If you could help me on this point.
Thanks you all

Hope this could help you

Cheers @vdarold

May be, you are printing the data using log message, this error usually occurs when u try to print too long data.

The error basicly say this. But there is no print logged anywhere.

Maybe Studio try, for is own execution, to retrieve the data to ensure that the activity worked well. Maybe it’s an internal exception in the Studio.

we might have extra OUT Arguments which are not used by chance or if used and is holding long data…
kindly check that once
Cheers @vdarold

Hi @Palaniyappan,

Thank for the post. It’s seems to be weird and the case is not solved completly.

We found an another way to make the process (write the datatable in a temp Excel file and read it later) to avoid using argument.

But I prefer to post the problem. Cause the method is not optimized.

Regards

2 Likes

awesome
@vdarold

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.