Issue-Orchestrator installing package stuck

Hi,

We have on-prem Orchestrator installed just a couple of days ago. I have published a newly created project and deployed it form Orchestrator and everything went fine but now as I try to deploy some of the existing projects to transfer them to Orchestrator the installing package is stuck and it just stands there saying ‘instaling…’
In the project I am using only the main UiPath packages with latest versions.
image

Found somewhere that it could be a package feed issue? Could someone explain it to me ?

image

Thank you

Hi @Petar_Soce

How are you trying to install package? Could you please share steps you are following here?

Second screenshot you shared is from assistant which is trying to install package to your machine from orchestrator.

Is this what you are trying to do?

If there are any changes in your package and you want to publish that to orchestrator , please do it via studio.

Regards
Sonali

Hi,

Step 1. Manually uploading a published package to the tenant
Step 2. Creating a new process and including that package
Step 3. Running the process

The assistant picture is from a production machine, that installing event is triggered after running the process from orchestrator for the first time.

Hi @Petar_Soce

Okay so you are trying to run your process from orchestrator which is not happening due to package not being installed.

In this case, please check if your production machine you are trying to run your process on is connected to orchestrator or not?

If it is connected fine and still not able to run process, can you check if you have a mix of classic and modern folders on your orchestrator?

Also, you can copy packages from your machine from below folder to this folder on production machine. By doing this, your process would run just fine there.
C:/users/your username/.nuget/Packages

Regards
Sonali

ensure that your machines / Orchestrator will have access to the internet / can download packages fro nuget feed. While rolling out a process the first time it happens often, that dependency packages has to be fetched.

On Windows Event log e.g Assistant machine you can check for further hints

Thanks,
Its connected. If I create a completely new process and deploy it, it works. The packages are installing a bit but eventually it starts up.
This problem occurs only on existing processes that I am trying to redeploy via Orchestrator.
Only modern folders are being used.
Will try other suggestions and come back at you, thanks

Copying the .nupkg package does not do anything, the Robot assistant is not finding that package. I don’t want to just copy unpacked packaged of the process since that beats the purpose of having an Orchestrator

Production machine has access to the internet, Orchestrator is installed on-prem, how would I check if Orchestrator has access to the nuget feed?

yes thank you, as far as I can now see I am quite sure it is the package/library feed problem. On the production machine we only have default, older, installed packages and I am trying to deploy a process with the new package versions.
But why the production robot is not fetching those versions from the official UiPath nuget feed I have no idea at this moment.

  1. I am not sure is the robot fetching those packages/libraries or Orchestrator should do that ?
  2. If I install a new package via studio on my development machine and publish that project to the orchestrator, is the new package version being added to the Orchestrator library ? ( at this moment our Studio is still not connected to the orchestrator so I have no idea).

was adressed with

as

nuget feed e.g. can be blocked firewall rules

try to start with e.g. manually upload the required dependency packages to Orchestrator
check the Bot machine settings that at least Orchstrator is confiugred as a nuget feed

Thanks,

Waiting on our IT department to check the firewall settings.
Should package feed to the uipath official be enabled somewhere from the Orchestrator backend or from the production machine ?

Hi @Petar_Soce,

Are you deploying packages at tenant level or folder level packages?

Also, is official nuget feed also enabled for your production machine? Please verify if feed settings on your machine and prod machine is all same in nuget.config file

Also attaching below documentation around activities feeds:

Regards
Sonali