Issue - Job stopped with an unexpected exit code 0xE0434352

I registered this issue in our internal bug tracker. I will update this topic with more information when it becomes available.

1 Like

I am facing this issue as well and have tried all the above - it is a show-stopper for our process. Is this a known issue, and is there a preferred workaround for it? Thanks to all!


Can you share some insights about this error as this is show stopper for us?

1 Like

I checked and the issue is still open for investigation. A couple of ways to proceed:

  1. If you are an Enterprise customer, you can try contacting our Technical Support for direct assistance:
    Contact Technical Support
  2. I noticed a mention recently that for big sets of Excel data, it might be beneficial to connect to it as you would connect to a Database.
    For example, see here, but also search our Forum, there is plenty of topics about it.

Is this issue open or is there a solution?

It is still an issue that is most likely linked to the amount of data you want to process at one time and memory limitations.

Feel free to add your:

  • Studio version
  • scenario in which you are reproducing this issue (a dummy, new project that throws the error for you is always the best way to report a bug)

Studio version:
Studio Pro 2020.10.2 - 10/23/2020
Community License
EXE Installer

License Provider: Orchestrator
Activation ID:

Update Channel: Stable

Microsoft Windows 10 Enterprise 64-bit
.NET Framework Version 4.8 or later

Scenario in which you are reproducing this issue: Test script reading an excel with 8 lines and checking the data with information on the screen.

Any chance you could create a dummy Excel file and send over a sample new project that reproduces the issue with such dummy file?

Hello @loginerror,

this occurs very often and is a show stopper.

Do you have an update on this issue?

Thanks for your feedback in advance!

@aaydin @Jhana.Horacio

Would you mind providing some logs using our:
(you can find it in your Start menu)

Please send them over by a private message to me @loginerror

It would also be nice to have a sample project that causes the issue. It is most likely related to some memory limitations.

Hi @loginerror,
I hope it helps you to analyze this problem.

I found a solution.
If you enter an empty range in Read Range Activity, then it works. Otherwise error occurs.

(in both cases I used the same sheet with over 11000 lines and columns from A to U)


Hi @aaydin

Could you try updating your Excel activity package in case it is not the latest version?

Annoyingly this fixed my issue too. The file type I was reading was an XLS so I’m not sure if it was actually having an issue of trying to convert to XML etc. But thanks @aaydin as this is me sorted!

1 Like

Did you get any updates to this? I’m also receiving this error inconsistently with the same source file.

UiPath v2020.4.1 (but there is a planned upgrade to v2020.10 later this month)
Excel Package 2.9.5

Excel sheet has 109K rows, but the Read Range of the sheet with “” is successful, but when I use Read Range with “A1:B”+lastrow (variable lastrow set via Assign), the activity errors with unexpected exit code 0xE0434352.

I’ve tried to add in a delay of 15 seconds thinking that if it was memory related, it might clear but that was inconsistently successful.

EDIT: @aaydin Thank you for your suggestion above. Based on what you provided, I removed the Read Range “A1:B”+lastrow that was giving me the issue and instead filtered the data table provided by my Read Range “” to remove the blank rows.

1 Like

Hi [vikashkumarvivek00],

Hope you get the Solution, i hope you have tried several points like delays and all, So here i have few suggestions as well i mentioned below:

  1. First kill excel in your code using kill excel activity - “/im excel.exe /f”
    2)Avoid reading excel with empty range means in “Read Range Activity” must pass any range e.g. if suppose you think that data might be “A1:M800” most of the time then try to use “A1:M10000” and the remove empty rows using data table filter
  2. Kill the excel again , Use the data from data table.

I am pretty much sure it will work!!

Hi All,

So, in case somebody comes here, and none of the other options works for him/her, let me share what worked for me since I was having the same issue:

  • I think my problem was related to the fact that all those read and write activities where inside a an invoked workflow, inside a Loop. At every second iteration of the loop, the function would throw this unexpected error. The thing that worked for me was to set the Invoke workflow as Isolated. Simple but it worked. Why it worked… Only the wind knows… (Or Vb.NET developer I guess…).

If somebody is doing these reads and writes of huge excel sheets inside a loop, and facing this issue, give it a try. Please, also check what are the consequences of invoking a workflow in isolation mode in the UiPath Documentation.


Hi, in my case I had a lost cell with some special information. I deleted all rows to assure that everything apart what I want was empty and it works. :slight_smile:

Hi @aaydin
I tried empty range with a smaller dataset still I am getting the error
any solution?

Hi @Aishwarya_Bhargava

can you share here a screenshot of your read range activity?


Any one with some other info around this. It is a show stopper for me and I don’t like it.
Thank you.