Issue in send smtp mail message

I am also stuck with this issue. Can anyone update on the solution? Most weird thing is that it works once in a while which means that connectivity is not an issue. I tried all the above suggested solutions but didnt work.

Anyone able to find issue? Mail service was working fine from last 5 months and suddenly from last 2 days it’s not working and throwing error as Timed out while waiting for Mail Service to connect. Restart of VM machine also not worked for me.

1 Like

I get timeout error too. Couldn’t find solution anywhere.

How does one add ImapX as a dependency to the package?

What I meant to say is you should add ImapX as a dependency directly in your process’s packages, through the package manager window. This resolved the issue for me because it forced that package to be downloaded. I had the package on my development machine for a different project but it was not downloaded on my client’s PC before adding it as a dependency of my process package, leading to the weird error message I posted about. To confirm whether or not you’re experiencing the same issue, look for the ImapX package folder in the machine’s nuget cache folder where all nuget packages are saved (should be named .nuget by default I believe in your user folder in Windows, but don’t quote me on that).

Joe Iaquinto

Thanks for the quick response.

I think you have a false positive there. I’m not having this SMTP problem on my development machine, but on my robot machines I am. I searched my entire hard drive on my development machine for the term “imapx” and got zero results.

I also copied the “packages” folder from my dev box to my robot in the hopes that would solve the issue, but it did not.

For now, I’m switching from using SMTP email activity to Outlook Send Mail activity. I’d prefer to use the SMTP activity to have the fewest links in the chain and therefore fewest chances at failure, but at least Outlook Send Mail is working.

1 Like

Facing the same issue in UiPath studio 2020.10.4 and SMTP activity version is 1.10.5.
Restart VM machine was worked for me before, but this time it is not working. I have already restarted VM for several times. Is there any sloution?

1 Like

me too, do anyone have the solution for this issue ?

Change property security level as none and try

Hello,
Is this issue resolved? I am using the latest packages now and the imapx as well. I’m still facing the same problem :frowning:

Timeout issue is often related to thr network restrictions. Make sure a test is always perform before putting in UiPath.

You csn test SMTP is working or not by using many options. One of them is below, using powershell.

This will let you know if there is any error, alternatively you can check the Event Viewer in your system to check if there’s any error.

I’ve tried this solution many times but still no luck. I don’t even know what kind of event/error/logs I need to look for in the event viewer as there are many things happening in there… The same thing with other people, if I will restart the VM, sometimes it will work and but usually, it does not work. I’ll consult with my network admin or server admin. I’ll post an update once okay.

Thanks for the reply, I appreciate it :smiley:

1 Like

I have a VM where until the studio update the send smtp mail worked flawlessly. After the update we even run a process which sends more than 30 emails via smtp. The next day another process run succesfully but the next one got stuck sending the email and did not timeout properly.
Until today the issue is still present.
Yesterday i faced the same issue on my notebook, which works with another orchestrator, and today the activity send smtp mail worked as expected.
I have tried using the Telnet app from windows but it seem to not work with SSL connections.

I suggest you try using Uipath Orchestrator.

Hello, Just an update… Before, I was using Gmail, but after I connect my Gmail account to outlook and use the outlook activities, I have never encountered any issue since then.

I had to abandon SMTP as a mail sending solution and instead I established an API connection to my Gsuite, which is working fine.

While this provides me the ability to continue to function, it’s not ideal that SMTP is no longer an option because of what has been reported here.

Hey all,

So we’ve seen this on and off with a few different processes. A restart of the VM / machine where we were running the send STMP message used to be the goto. I recently found that quitting the uipath assistant and signing back in would also correct the issue and allow me to send.

Does anyone know if an older version (and if so, which one) of the mail activities works effectively?

Also, has anyone submitted a ticket regarding this issue into support? I’d love to know what the official response is to this issue.

Cheers!

dw

Hello, any solution to this problem.

It worked fine for me until today, I have tested and the connections are correct using the same smtp with Thunderbird.

If I configure gsuite or outlook as an alternative, will it work?

a greeting

I had the same issue. Upgrading UiPath Studio to the latest version available fixed the problem.

The probable cause could be compatibility between UiPath and Outlook (in my case)

@pushpa.k
hi,
Have you got any solution for this error.