Issue in passing a item from Datatable in the app to a string argument in the bot

Hello All,

I have an UiPath app, where I have a set of text boxes. They are filled with values coming out of a DataTable (contains only one row). While displaying, it works perfectly well.

As a next step, the user edits some values and I have to pass the values from the textboxes back to the bot into String arguments.
But when they are passed, they are passed as arrays instead, with β€˜[" "]’ in the string.
I could manually do a string replace for the characters for all arguments .
But is there a more cleaner way to do this?
Is there any way to pass a string from Apps instead of the array?
I tried using a Data row instead of a Data table but with no effect.

Would greatly appreciate any help. Thanks a lot in advance.

1 Like

Hello @Kiruthika_Nithyanandan ,

Can you please share your mapping screen?


Here it is:

When the text box is populated:


This is where the value from the text box is passed back with input override:

Thanks a lot for your help!

@Kiruthika_Nithyanandan ,

what is In_emailAdresse field type? If this is not string please change to string and then refresh it and remove this rule and re-add .


Hello @Arvind_Kumar1 ,

It is already a string argument in the bot.

Thanks and Regards,

I think what Arvind means is to change the variable data type on this process argument from within Apps.

You can expand your RPA process on the left in App Studio which should show the input/output properties on the center panel… From there, expand the relevant section (input, output, etc) and click on the small icon to the left of the property name and you should be able to change the input property to a string type if it is not already a string.

Sometimes, these properties get out of sync with the process in UiPath Studio and it causes some bugs like this.

Hello @Krollythegoalie,

Thanks for your reply.
I tried to change this in the app, but it was already of string datatype.
Here is the screenshot:

Could it be that, because a data table is bound to a text box, App considers this an array instead and converts it to string while passing to the bot?

@Kiruthika_Nithyanandan ,

Please find below.

Option 1:-
Please remove the binding of field with Input control and try again.

Option 2.:-
Can you please run the process from orchestrator and try passing a string and test result? if this work please remove complete control and Pass some hardcode value then map with input control

If you are still unable to fix. I would be happy to help on screen share.

Let me know what is best for you.


Hello @Arvind_Kumar1 ,

Thanks a lot for your reply.
I will try these two options and update again.

Thanks a lot.