Issue executing Powershell scripts on VM bots

Hi all, hope you can help with my issue,
So I created a powershell script to rename the Sheet name from a bunch of excel files( I cannot use excel scope since its a background automation, that’s why i’m sticking to the ps script), In local machines the script works perfectly well, when i run it through uipath in my local machines is also working perfectly fine, the issue comes when I upload my package to orchestrator and run it from there into a VM, then the horror starts, the error I got, is this
Invoke Power Shell: Microsoft Excel cannot access the file ‘\cap024prot\EM_SSS\RPA\UiPath\Support_Files\AMER2019021_S2-SalesOrderAutomationExcelCustomers-ExcelFiles\QueueFiles\40002882-32894.xlsx’. There are several possible reasons: • The file name or path does not exist. • The file is being used by another program. • The workbook you are trying to save has the same name as a currently open workbook.

Obviously i checked that the excel files is not open by another instance, and it does exist, and there isn’t any other workbook with the same name.

I was able to isolated the line in the powershell that throws this issue and is this
$wbExcelFile = $objExcelDocument.Workbooks.Open($sExcelFilePath)

Where $sExcelFilePath is received from uipath with this value \cap024prot\EM_SSS\RPA\UiPath\Support_Files\AMER2019021_S2-SalesOrderAutomationExcelCustomers-ExcelFiles\QueueFiles\40002882-32894.xlsx

Something to note is that if I run the script manually in the Vm, it works, it only fails if I run it through UiPath ( or more accurate through a bot from orchestrator)
I have tried some similar solutions on the internet that include adding this folder in the vm
and give the vm user full control of that folder and the one in the shared folder

I have tried ( as testing) changing the relative path to some absolute path inside the vm, but no luck, either way i need it in a shared folder.
Any ideas?