Issue embedding double quotes around String

Hi All,

I have come across a peculiar problem while running a workflow on a different laptop. The workflow was running without issues on the original laptop that was used to design the workflow.
The issue seems to be simple and is with a “type into” activity which types into the bing webpage search box.
I need to embed a string within double quotes. This was working as expected on the original laptop but when I tried to run this in a new laptop, there seems to be some special characters appearing instead of double quotes.

Below is the string that should be typed into the search box.

“site:” + URL.ToString.Substring(4)+" “+”"“AS400"”"

A correct sample string typed in should look like the below.

site:bfa.ao “AS400”

But instead, it is getting typed as shown in the image below.

As can be seen, the first “A” character in the string gets typed into as Ä and the double quote is missing.

Please help why this is happening so.

Image mentioned in above question is not appearing.

Below is how the text gets entered.

site:tiranabank.al ÄS400"

@thejwal_pavithran, It is because of special character. Usually it happens if you copy paste code from somewhere. Please correct the quote and it should work fine.

Cheers

“site:” + URL.ToString+" "“AS400"” “

In Details

Try this

Thanks

Type the below line in the editor window. (Copy pasting from here sometimes changes quotes to special characters)-

String.Format(“Site:{0}”“AS400"”", URL)

After breaking my head for hours, I found out that it is a common issue with dell laptop language settings.

As I mentioned already, the workflow was having issues with only one laptop. I changed the language settings and now it works as expected.

Below link to the dell forum post.

https://www.dell.com/community/Laptops-General-Read-Only/quote-and-quot-double-quote-quot-key-issue/td-p/3970396

1 Like

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.