Issue about attaching to a new tab and sending hot key to the new tab


#1

I am trying to download a pdf file from a website using uipath.
When I click the pdf link, the pdf file appears in a new tab in the browser.
Then, I try to send hot key with CTRL+SHIFT+S. However, there are errors when I try the following 2 methods.

  1. Add attach window and click indicate on Screen by dragging the activities into the workflow. --> can’t find the UI element
  2. Use the record function to send hotkey in the tab. --> write text error

Anyone know the reason behind? Seems that I can’t interact with the new tab and can’t send out the hot key (CTRL+SHIFT+S).


#2

We also faced same issue with one of my previous project… please check the link of new window opened and try to generalise the link. This may not be applicable all the time. Some times link will be generalised with system date or some specific code value if it is Web application.

Also try activate activity it also may help. It may not be problem with UiPath…


#3

This is another way to download, incase if you want to try

image

http req properties

image


#4

@vvaidya

I tried http request many times to get pdf and csv data from public websites NSE and BSE but I could not able to download I used to receive empty file I don’t know where I committed mistake. But I haven’t tried with get attribute option. Thanks for information let me try again and I’ll get back to you if I face any issue

Thanks