Is it possible to setup Community Edition of UI path on Windows Server 2016?


#1

Installer(.exe or .msi): .exe

License type(Free, Trial/License code): Free

Studio/Robot version: Studio

Current behavior: After installation, when prompted to activate license, I attempt to register for the Community Edition license, however, this throws the following error:

Activation failed with error: 0
Error description: Cannot use Community Edition on this machine after activating a trial or Enterprise license code. Please enter a valid license key.
License status: Device ID already activated

Device ID: mu/UC314jdCMo9Pk3Hcp
Computer: EC2AMAZ-3H4T68A
User Name: Administrator

Screenshot:

I am wondering if this error arises because the community edition license is prohibited on Windows Server.
I have followed all given instructions up to this point.

Any help would be appreciated. Thanks in advance.


#2

i’ve installed community several times on windows server 2016 without any issues


#3

I’m actually installing it on an AWS instance… ie the Windows Server which I’m installing UI path on is running off Amazon AWS… do you think this could be the problem?


#4

what is the file name of the msi installer that you’re using?
Only if AWS discriminates against system installs versus user/ (%localappdata%) installs … could this be a problem … Not familiar enough with the privileges granted via AWS , but ideally you would have local administrator rights on the host for proper installation of UiPath or any development environment


#5

I’m using UiPathStudioSetup.exe
Although it seems that UI path isn’t allowing me to register this license as opposed to AWS not allowing me to.


#6

try obtaining a ‘UiPathPlatform.msi’ to install in progfiles instead of localappdata


#7

Hi folks,

The error doesn’t have anything to do with the installer, but with the fact that a license code was previously used to activate Studio on that device ID before (it may be a Trial code). So @Nathanael is your aws machine cloned?


#8

Hi Ovi,

I am pretty new to using AWS but I believe that my instance is not cloned. It was a new instance launched on its own.

Thanks!


#9

@Nathanael I have sent you a PM requesting your Device ID so we can investigate.


#10

Hello UiPath support, I’m experiencing the same issue on a brand new instance running on AWS that I have never installed UiPath Community Edition before. This is my first time installing on this machine. I’m getting the following error message on first time install and start up of UiPath Studio after entering my email and using the default Device ID provided as part of the install:

Activation failed with error: 0
Error description: Cannot use Community Edition on this machine after activating a trial or Enterprise license code. Please enter a valid license key.

License status: Device ID already activated

Device ID: XXXX
Computer: XXXX
User Name: XXXX

I’ve replaced the private information above with XXXX in this post.

I tried also going to your renew license page as indicated in another post, but that didn’t seem to help.

https://www.uipath.com/renew-community-license

Any way to correct this? Let me know if you need any other information. Thank you.


#11

Just wanted to follow up on this. There seems to be an issue with running the community edition on AWS as I was able to run the same install successfully on an Azure VM without the issues described above on AWS EC2. It seems as thought the Device ID registration or something as part of that process is not working on AWS for some reason. Looks like this issue has been previously reported on the forum, but with no obvious solution from what I can tell:

Any further information you can provide on making it work on AWS would be much appreciated. Thanks.


#12

Hi guys
The problem was solved by installing the “.net 4.5” update.
At the beginning I also had problems in AWS, then I installed UIpath in Azure and had the same problem. Finally, the problem was solved in both clouds by installing the update.