Is admin rights required to perform Recording on Web Browser?

I am trying to record a simple task which involves i.) opening a web browser ( and ii.) then entering relevant text into the Search Bar.

I was able to record the first step via “Open Browser” on the Web Recording pane. Upon clicking the highlighted IE browser window, i was prompted to enter the URL, in which I entered So far so good.

For the second step, I loaded on IE. Then I clicked “Record” but was unable to highlight/select only the Search Bar on Google in order to enter text. Instead, the entire window was highlighted when I moved my mouse over to the Search Bar.- see below

Upon clicking, I received the following error message.


Does UI path require admin rights in order for actions to be recorded on the web browser during Web Recording? I just want to be sure before actually requesting for admin rights as it is a long and cumbersome process to do so.

I tried running a similar Process provided by Lesson 4 Practice 2 (“Get Temperature”) but got the error message below. Not sure if it is related to the same admin rights problem where the rights are required for the robot to interact with the browser.


Get Temperature.xaml (10.0 KB)

The Get Temperature exercise (as attached) involves first typing a City Name, which the robot will use to input in

Can anybody advise?

1 Like

add the webpage to trust list in Internet Setting.buddy
that would work for sure @Chinhian
for more insights this would help you

1 Like


Thanks for your help!

Indeed the problem was related to admin rights. I figured out when I used another laptop in which I was the admin - it worked. With regards to your proposed solution, I would not have been able to set as Trusted site without admin rights.

1 Like

Thats great
Cheers @Chinhian