"Invoke workflow" sometimes doesn't allow me to change it setting

Hi

Presently I’m doing Level 3 Assignment 1 and using REFamework and Invoke workflow.

But it’s strange that even I want to change the argument setting, for example I have an argument “out_Password”, for a mistake I set its direction as “in”, now I want to make it correct to “Out”.

However, even though I do it several times, every time after I switch it to “out” and click OK.
Next moment when I click Import Argument for checking, it still turns back to “in”.

What is the reason of this issue?

Did you save the sub-workflow after change scope of argument?

Yes, I saved it.
And also I tried to reopen the Studio, but it doesn’t work.

Why do you need to " click OK"?
Is there a confirmation pop-up when you change the scope?
On my pC, there’s no Ok button for click when changing scope of argument

Here is the pic when I change the setting of the argument out_Password as “Direction=Out”, and “Value=Password”

After I click "OK button"m and click “Import Arguments” for checking,


It turns back to the origin setting.

I got it!
If you want to update the Direction of argument, you must open the sub-workflow, in this case, you must open GetAppCredentials.xaml file. Then go to the Arguments tab (beside Variables tab) to change to Direction of argument.
After change & save the sub-workflow, you back to Invoke Workflow File activity, click on Import Argument -> new direction of argument will be displayed.
Don’t change the Direction of argument in setting of Invoke Workflow File activity

1 Like

Thank you for your help, it works!

Now I know how to set these arguments.

It really confused me at the beginning.

Again, Thank you, I completed my first assignment of Level 3 :slightly_smiling_face:

1 Like

You’re welcome!

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.