Invoke workflow passing null value


I am working with Assignment1 using Reframework.
In Init stage after InitAllApplications workflow I have invoked ExtractWI5WorkItems workflow to extract all WI5 data from ACME system1 in a Datarow variable named WIList and passing it to next stage Get transaction data.
The issue is
Within ExtractWI5WorkItems workflow WIList variable holding the correct values, but as soon as ExtractWI5WorkItems is closing I saw WIList becoming null so it is passing NULL only to init stage. What is the reason I am not getting:worried:

Please help.

Greetings @GargiMitra,

I see two possible reasons why could have this happened:

  1. It may be that you have declared a variable with the same name within ExtractWI5WorkItems workflow, and you assign a value to the variable, but not to the argument.

  2. You have declared correctly WIList as an argument, but it is not an Out argument.

If you could share some images, we could be of further help!

Kind regards,


Yes your prompt reply solved my issue.Thank you so much!:+1::+1:
A great help indeed!


Iā€™m glad this helped you.
Could you mark this thread as solved?

Thank you!

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.