Invoke Workflow: Could not find file

Hi Community,

I have a strange issue which I cannot explain:

Using the “Invoke Workflow Activity” on a certain position in my project results in a “Could not find file” exception.
image
The strange thing about the exception is, that it states as path my custom librabry path (“C:\users<username>.nuget\packages<custom lib name><lib version used in project>\lib\net45”) and not the actual file path (which is of course in the project)
The invoke activity has a relative path as property.
Also it only happens on a certain position in the project.
All other invoke workflow activities before run fine

I tried the following:

  • Changing the invoked workflow will result in the same exception
  • using a absolute path runs the workflow without an exception
  • it only happens at a certain position or after a certain amount of invokes have run before.
    So when I comment out the invoke right before the affected the exception will happen one invoke later
    To ellaborate:
    the failing invoke is the one with the breakpoint
    image

    Just as if there is a limit of invokes that may run in a project …

Anyone has any suggestions what might be running wrong here?

Thanks

Hy @RPraschma,

If you run the process in your local studio, rather than in Orchestator, does it work?
Check the dependencies for this workflow to see if everything is there ok

Regards

@William_Blech_Sister
I am running it in studio. Even in Debug I get the exception.
Dependencies are not the issue since the workflow will run if it is not the 19th invoke but the 18th or less

Btw. as a Workaround I just do not have the workflow “code” in a separate workflow file, rather in just a separate sequence inside the parent workflow.
This way it works fine

Update:
Workaround leads to a complete avoidance of the invoke workflow activity, because the RE-Framework uses up all the available invoke workflow “capacity”.
This makes the code more or less unmaintainable.

This is not a sole Studio issue.
I published it and ran it on another machine, and the same exception happens.

Hy @RPraschma,

I really did not understood you, in ReFramework we are supposed to use InvokeWorkflow.

What do you mean by "because the RE-Framework uses up all the available invoke workflow “capacity”.?

Regards

hi @William_Blech_Sister,

Yes in the REF you are supposed to use InvokeWf.
Which I also succesfully did until now.

But the REF has some Invoke WF by itself (e.g. “Invoke KillProcesses” or “invoke Initialise Application”)

My strange problem seems to allow n times to use the invokeWf activity.
On the (n+1)th time it throws the above mentioned exception.

So it seems there is a limit or maximum capacity of invokeWf I am allowed to run.

So now I am not able to use additional invokeWf activity, because it will use up my “invokeWf-Capacity” and then the invokeWf of the REF will not work.

FYI: I am writing a support ticket about this issue.

I got curious with this and will make some tests here, to see if i get the error as well.

Well, in my test, i created a new REF template project and i processed 5 queue items and in the Process Transaction phase, i included my own 10 custom invoke workflow file activities and got no errors… So just with my own invokes, not including the ones REF already have, i just executed over 50 invokes with no limits…

Hi Praschma,

I am facing same issue like your’s but I am not using RE Framework. I’m getting an error i.e “Could not find file”\path’" where I have used invoke workflow file or Launch workflow interactive. Before this step other invoke workflow file is getting executed.
Here I have restarted the windows file from task manager, UiPath Robot restarted, Application which I am using for my use case every thing has been ended from the task manager.

Could you please let me know, How did you resolved this issue?

Thanks & Regards,
Suma

Hi, has this issue been solved? I have same kind of issue. If testing with a throw exception activity then it finds the workflow. But when exception happen within a SAP activity it doe snot fin the workflow. (workflow is for sending email if an exception incurred)

Is issue related to own created activities?

Actually I did not truely resolve this issue.
According to UiPath support this is an issue which occurs when using custom libraries.
The issue should not occur when the libraries where build using a current studio version.
Unfortunately the issue still happened when I got to test it again.
I had to workaround by not using custom invoke workflows at all (only the standard ones from the REF). I just pasted the code from the xaml file into the process.xaml (and clustered it inside an own sequence to make it a bit more visually accessible).

Maybe the rebuilding you custom activity will help you.