Invoke VBA is not working

Error Message:

I have enabled the settings same as the above error is showing, still no luck.

Please help if you have any idea about what I am missing.

Hi @shreyash_shirbhate ,

The steps you have followed to enable the macros in Excel is proper.

Can you restart the system and try once?


HI @shreyash_shirbhate

Have you added the trusted location in the Trust center settings?


Add the trusted location and select subfolder also trusted and add the main folder there and try to run the process again


Hi @shreyash_shirbhate

Have you done all the things in the below steps :

Step 1 Open an Empty excel or any excel file
Step 2 Goto File-> Option
Step 3 Goto Trust Center → Trust Center Settings → Trusted Locations
Step 4 Click on Add new Location and browse for the folders (Project Location) and check the Sub folder of this location also trusted and click on ok
Step 5 The Location will be added in the list of trusted location and click on Ok
Step 6 Goto Trust Center → Trust Center Settings → Macro Setting, enable the Trust access to VBA project object model and click on Ok


1 Like

Hi @Sudharsan_Ka,

I have added the location as you said, still the same error.

Done All the settings, still no luck!

I am frustrated now! :sob:

Hi Guys @Gokul001 @Sudharsan_Ka ,

I tried restarting my machine as well but it is not working.

Can you check if I am doing anything wrong?

Hi @shreyash_shirbhate ,

Can you try changing the extension of the VBA script file from .txt to .vbs ?


1 Like

Still the same error, Not working.

The method name you have mentioned seems to have a typo ChnageFormat, can you check and verify if it’s the same method you have used in the script. @shreyash_shirbhate



@Gokul001 @Sudharsan_Ka

I am trying to change the format of entire column from General to Text using VBA.

But it there any other way I can do it as VBA is not working?

Instead of saving the code in the txt file save i as .vb and use that in the path and try again @shreyash_shirbhate

Thanks Vishal it worked! There was the typo in my code.

But UiPath Should give the different error saying the method not found or something similar like that rather than giving the below error repetitively.

I am tagging @loginerror here to change the error message of such kind of scenarios.



@shreyash_shirbhate , usually it gives the error that the method is not found as below, not sure why it didn’t in your case.


1 Like

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.

Thanks for mentioning it. I’ll pass your feedback on to the Excel package team.

1 Like