Invoke Method - Despite declaration, column name missing

excel
robot
activities
studio

#1

trans_updated.xaml (15.9 KB)
Hello Everyone,

I used Add column followed by Invoke method to add a new column to my datatable. However instead of column name, I am seeing the column default value. Can you please help me with this? Screenshots below

1

23


#2

Hi @Selvasathappan
Please find attached solution and check if it works for you.
Transpose.zip (8.3 KB)
Thanks


#3

Hello Bharat!

Thanks for your solution. It worked. I will mark it as a solution. But it would be helpful if you could just let me know what was the mistake which I did. As I am a beginner it would be helpful.

The approach what I did seemed to be fine but wasn’t just printing the column name.

And one more question, How can I prevent the headers being printed every time when I run this program? As I am appending the data, I don’t want the headers to be printed every time I run this script. Just one row at the top of the excel should suffice

See the screenshot below.

1


#4

Hello @Bharat, Can you please advise me on the below scenario. I know to add a new column withd efault value but how do I approach this scenario