Invoke argument values input is overwritten with default value from invoked workflow arguments

Scenario:

I have recently discovered a dangerous bug, that the default value from a workflow component is transferred into the import arguments value field in the invoke workflow activity.

  • I have seen Empty values being overwritten with ‘default value’ containing a string.
  • I have seen Filled values being overwritten with ‘default value’ containing a string.
  • I have seen Filled values being overwritten with ‘default value’ containing nothing.

This is dangerous since I can change something one place in a process, and when I deploy it I will actually introduce an error into production. This have happened, and I actually don’t have a full overview of how many of these errors that I have put in production.

Steps to reproduce:

This happens sometimes when I open the main process file, and not only when I click ‘import arguments’.
Workflow component
image
Invoke workflow, Import arguments
image

Current Behavior:

Replacing input value with default value

Expected Behavior:

Not replacing input values in invoke workflow activity

Studio/Robot/Orchestrator Version:

Last stable behavior: Not sure, possibly 18.3
Last stable version: Issue happens on 18.4.4 and 18.4.5
OS Version: Windows server 2016

Since this is only happening sometimes, it is really hard to document the procedure of reproducing. So it would be really greate to hear if anyone else have seen this issue, and possibly is a step closer to understanding why it happens.

2 Likes

Yes, lately I’ve been experiencing this. I can’t recall UiPath Studio acted like this before.

Steps to reproduce, but doesn’t always work I noticed;

  1. Put in your invoked workflow somewhere in the code

  2. Click import arguments and enter some input value to your arguments. Save.

  3. Open the invoked workflow and enter some default values to the arguments. Save.

  4. Go back to your code where you have invoked the workflow. Click on Import Arguments.

Now the input argument values are overwritten with the default values (that you wrote in, in step 3.).

It’s quite annoying because many times you write in a default value to test your invoked workflow independently from the rest of the code. And then when you try running your whole code, an error is thrown because the input value fields have been replaced…

/d

1 Like

This was a Bug fix released in System 19.2. https://activities.uipath.com/docs/release-notes-system#section-uipath-system-activities-v19-2-0
This was done because old functionality broke default values for Int32 and Boolean when you left Value blank in Invoke workflow file.
When you Import arguments now, if the Value field is empty, it will bring the Default value from the Invoked workflow. However, if the Value field has something, it will not touch the value.
@Dan_Wulff_Andersen I haven’t managed to reproduce any of the cases you mentioned. Do you have more details?

1 Like
  1. In a new sequence, create a string in_argument and give it a default value. Save & Close

  2. Create a new Sequence, invoke the workflow from step 1.

  3. Click “Import arguments”. The value field will have the default value you assigned in step 1. So far so good.

  4. Change the default value to something else. Click OK and close Sequence window.

  5. Open the same sequence again and click “Import arguments”.

The value is now replaced with the default values from the invoked workflow, even though we changed it in step 4…

1 Like

Thanks @dVni Good to hear I’m not the only one with this issue.

@Corneliu_Niculite
I have a support ticket 00046189, you will find vidoes there.
I get the error with UiPath.system.Activites and UiPath.UIAutomation.Activites v. 19.2 and with v. 19.3

1 Like

Any update on this?

  1. Using 2018.4.1 studio and facing same issue.
  2. Not happening all the time though!
  3. Initially it only got the default values if there is no input value provided.
  4. But now it is even overwriting the input values. Sometimes this can only seen after relaunching studio.
1 Like

@Dan_Wulff_Andersen By any chance are you using TFS?

1 Like

Good to hear I’m not the only one with this issue.
Any solution?

1 Like

@Dev4005 Yes, I’m using TFS.

@wjian No, still no solution.

A fix have been made by Uipath to UiPath.system.Activites and UiPath.UIAutomation.Activites v. 19.5
Unfortunately it is not working either. When clicking import arguments, then all variables assigned will be cleared. Unless a default value is set, then it will not be cleared.
This is a big issue when you add an extra argument and need to update/import it to your main process, then all the variables that were previously assigned to an argument will be cleared.

1 Like

I have the same issue. I have a state machine. Inside one of the states I invoked a workflow. Not sure what happened, but after binding the parameters to local variables, the workflow clears out all local parameters you have set. Immediately.

The sub-workflow’s output parameters are there, but whatever you type in the local variable boxes while importing get immediately forgotten after pressing OK. It must be specific to the project file, as I have opened an older project and that one still can set, delete and re-set the inbound parameters (albeit that one does not use states).

It’s a pain, but it looks like I will have to re-write the whole app. Luckily only one day into developing, and I think the workflow files I can move over. I hope.

1 Like

Nope, it’s not the workflow. My install must have got corrupted.
Tried a new project with the old sub-process: it could not import the params.
Tried a new workflow in the new project, not using states: it could not import the variables. After clicking OK it forgot everything. Will uninstall the studio now.

1 Like

Same issue here. I am using Studio 2018.4.4

1 Like

Meanwhile I found a workaround.
If you click on the ‘Import Arguments’ box, then you have this issue.
Instead, if you click on the right side panel on the Arguments (Collection) and then click OK, you will have the arguments saved.
I was doubting whether it relates to using studio in Dark mode. It isn’t. I re-installed (in the same old default directory everything) and tried it in default mode, and it still had that issue. Good news is that this workaround can get me through while awaiting a fix.

4 Likes

Can Confirm. This is working. Thank You. Regardless of mode either dark or light. It will work.
Thank You , But Uipath team needs to work on it. It is an old bug which came back.

Good news everyone.
After a short test it looks like the issues with invoke, have finally been solved in 19.6 of UiPath.system.Activites and UiPath.UIAutomation.Activites.
19.6 is still in beta. Public release is expected in 1-2 weeks.

1 Like

The issues have been fixed in 19.6, yes. The old Edit arguments panel is in the Properties panel, in case you were wondering why they have different behaviour.

1 Like

I am suspecting some integration issue with tfs. But, this is not happening to all the projects.

2 Likes